Problem with Cg profile ARBVP1 and nvidia 53xx drivers

I would like to know if any body had the same probleme after installing nvidia drivers 53xx on a GeForce4: I had a program using the ARBVP1 profile for vertex program that worked fine with drivers 52xx and that now produce the error “unable to load program” when calling cgGLLoadProgram(vertexProgram).
The profile seems to be no longer suported by the driver, very strange…

Try calling glGetError() before cgGLLoadProgram(). Its possible some OpenGL code that is executed before cgGLLoadProgram is causing an OpenGL error, which will cause the function to fail with that error.

I have alredy try it and thant did not change anything. There is no previous error. The exact message is “CG ERROR: The program could not load”.

Does it work with the vp20 profile?

I had similar problem with cubemaps, when code refused to run on FX5200 after resize & glError returned invalid param. But with new drivers & on other machines everything was smooth.

It’s not easy to test it with vp20 because I use glstate. I have removed code of my vertex program and with only a “OUT.position=IN.position” like code, it work with vp20 but not with ARBVP1 that still generate the same error. The problem seems to really come from ARBVP1 profile.

cgruntime as well as cg compiler itself are very buggy.You’ll do your best if you compile the program with cg and hand-tune it.

Could you post your assembly output?? Are your standart arbvp’s working? What about vp30 path?

[This message has been edited by M/\dm/
(edited 02-09-2004).]

Beta cg 1.2 is out on nv site.

No CG profile works on my Quadro FX. Just claims that no profile is supported. I’ve seen this before when you haven’t yet created a gl context, however this time it’s different because no CG samples work at all.