problem replacing opengl32.dll and game il-2 1946

I dont know, if this is the right forum for my question, but i hope someone can help me.

I try to intercept opengl calls from the game il-2 1946 with glintercept. I put the glintercept opengl32.dll
and the gliconfig_fulldebug.ini (renamed to gliconfig.ini) in the game application directory. If i start the game it
exits very shortly after without displaying anything. The game logfile says it can not create the opengl context.
gliInterceptLog.txt also says that wglCreateContext() returns Null. GetLastError() gets ERROR_INVALID_PIXEL_FORMAT.

Further i tested if the game even runs if i remove the glintercept opengl32.dll and only place the original
opengl32.dll from the system32 directory in the game application directory. So there is no glintercept involvement
at all. Still the same error occurs: the game exits shortly after starting and the game logfile says it can not
create the opengl context.

Has anyone an idea why this error occurs? AFAIK there should be no difference between loading the opengl32.dll from
the system directory and loading the same dll from the application directory.

Maybe the game detects that the dll is not where it’s supposed to be :slight_smile: ?

Thats what i thought too. Some kind of cheat prevention.
But if i run the game with the glintercept dll it gives me the following logfile:


So it seems the game calls the right functions with the right parameters. But wglCreateContext() still fails. :frowning:

Maybe game checks for multisample pixelformats and creates temporary context?

If there is a demo of this game, can you post a link as I’ll have a look.

“il-2 sturmovik: 1946” is the latest game of the il-2 sturmovik series. I only found a demo of the first game of this series: link
I tried to run glintercept with this demo too and got the same error.