Possible OPenGL prob...Black Hawk Down game

Hi all…
I play Novalogic’s Black Hawk Down and recently started getting SYSDUMP.txt errors when the game would freeze and I would have to try to restart the game.
One very strange problem that also occurred was that when I closed the game my cursor would be limited to an “invisible” box on my desktop.
I recently built a new PC in hopes of having a spankin new, probelm free machine.
The new machine is running WinXP and has the following components…
ASUS P4S533-MX mobo with SiS videochipset
1 gig of DDRAM
2.4 Intel CPU
ATI Radeon 9600 Pro

I am still getting the problems in that I enter a multiplayer server and I can play for a few seconds…sometimes a few minutes…and then I freeze up.
I found the “3D” option in my ATI menu and selecting it prolonged my gameplay for a few minutes but I got the same problem.
I searched the ATI site and it directed me to Microsoft for a file called “openg132.dll”.
I can’t find the file in my new PC and I am supposedly running the Service PAck 1a.
I am also using DirectX 9.0b.
I am stumped.

Does anyone have anyy suggestions or know where I can find the missing dll?

Thanks in advance.


Search the XP cd for that dll or copy it off of a buddies.

Thanks for the suggestion but I did try looking for the file in my XP disk and it wasn’t there.
Since my post I stayed up an entire night trying to figure this problem out.
I managed to remove and un install my ATI 9600 card and loaded up the software/drivers for the onboard SiS chip. I started BHD and IT WORKED! Without the Radeon card.
The display was 1024 and it was very slow but I didn’t get booted from the game.
Clearly the problem is with the Radeon card and the Sis Chipset. Moreover, it’s a real mystery.
The Sis Vid chipset does not default to an external vid card. The Bios settings needs the “onboard VGA” setting to ENABLED in order to load the Radeon drivers. But when the monitor inputs are changed from the onboard connector to the Radeon card the system doesn’t recognize the card. This seemsto be because the Radeon instructions clearly state that the chipset has to have the SiS AGP drivers for the Radeon to work. The problem is that you can’t uniinstall the Onboard drivers without eliminating the AGP drivers from the chipset.
It really sucks.
Either Asus better come up with a way of keeping the AGP drivers only on the chipset, or Radeon better come up with a way to load the vid card with it’s own SiS chipset drivers for the card.
At this point I’m ready to buy an Nvidea (echhh) card to test my theory.
Of course, there’s no fix to be found anywhere for my ongoing headache.



Below is a post that I made on DFArena that may help some of you.

First, I’d like to thank everyone that posted suggestions and ideas on this thread.
It wasn’t many of you but that, in itself, says a lot about you and people that try to help fellow Nova gamers. So thanks to all that contributed.

Second, as I posted here previously, I built a brand new PC just for Nova gaming. (Yeah, I know. I’m nuts!) All the components were brand new and I was getting SYSDUMP.TXT errors and display freezes during the games.
Well, after over 60 hours…yes, 60 HOURS…of configuring, reconfiguring, web surfing and even buying a second, new graphics card, I finally found the cause of my problems. I am posting it here in order to help anyone else that comes across similar headaches.
One word…MEMORY!
When I built the machine I bought and installed two 512 meg CORSAIR (model number VS512MB133) DDR memory sticks. I would NOT recommend this brand to anyone…ever! The best memory chips, to my knowledge, are made by CRUCIAL and/or KINGSTON. After all, memory is an integral part of the Nova gaming footprint and gamers shouldn’t sell them short by using cheap mem sticks.

FYI…after having ripped my hair out, lost days of sleep ( I was starting to look like a distant relative of the Unabomber) and tearing the new machine apart, I finally got around to testing the memory sticks.
I should also mention that this happened after I checked all XP docs for OpenGL problems (there are a few), ATI OpenGL probs…also a few, onboard Soundcard vs PCI Soundcard conflicts, blah blah. You get the picture.
Enough bantor.

Anyhow, I found a great website that has free progs for memory diagnostics that I’d like to share with all of you…
www.MemTest86.com This site rocks and is a MUST HAVE bookmark for anyone that is a serious gamer or is building his/her own machine.
The memtest program is free and does a thorough series of diagnostic tests of your memory sticks on your machine. The prog, called “memtest”, can be downloaded to be used on a boot up floppy or, like in my case, you can DL the ISO image file that you can burn onto a CD to create a boot up CD. (Shut your machine off, insert CD and restart PC. Memtest will boot and start, and perform the appropriate tests.)
When I did this, the prog went through a long and thorough series of tests. (yes, you should be patient cause they are long tests) The beauty about this program is that it will tell you how many errors your memsticks have, and by reading their locations, you’ll know which stick is bad.
For example, I had two 512 sticks. All errors…495 in total…were listed as being in memory locations 520 +. This told me that the bad stick was in DR slot 2…the second stick.
Once I removed it, I rebooted machine and loaded BHD. It worked perfectly! No sysdumps. No freezes. All gone.
I am now awaiting two, new CRUCIAL mem sticks that I’ll be installing this week.

So ends 10 days of blood, sweat and tears. No one should have to go through that experience, so I hope that you can use the info contained herein for your diagnostics and, more importantly, your sanity. Hope it helps you.

Thanks to all.

JJ_ST1 www.ST1USA.com
Comments can be posted here or emailed to me at JoJo@ST1USA.COM

Well well
Did you install the new memory sticks already? Sounds like the problem is caused by either not properly configuring your ASUS bios settings or by the wrong slot jumper settings. You need to check the integrated periphals settings in your bios and make sure it configures the right type of video card (wich you need to indicate by a jumper as well when building)

I d say you bought the new memory little too early. Btw; Unabomber look sounds familiar as I have been sorting out exactly the same problem. Solution came a little cheaper though…

Thanks for your post but I resolved the problem a few weeks ago.
It was a bad memory stick.
When I built the PC I installed two 512meg Corsair sticks. Wouldn’t you know it? After testing everything and practically pulling out the few hairs on my head…
I discovered that the bad stick was the second one…from 600 to 900 range. 496 errors in all.
By the way I discovered the problem by using a free prog called MemTest that is the best memory tester I’ve found to date.
You can DL it at www.memtest86.com
It’s a tool that every PC user should have.