orthograqhic view with depth function

My problem is I want to draw a circle but it should not change its dimensions when model is zoomed in/out.
I achieved it by drawing circle in orthographic view.
Now the depth function is not working, it is always front to the camera.

Can anyone give some idea how to achieve the following.
"The circle should be drawn with depth enabled and satisfy the above conditions.

Or is there any idea to achieve this in any another way