OpenXR Developer Tools Crash to Desktop when started

I have the above problem on one PC. Normally OpenXR Developer Tools works fine and has worked on this PC before. Another different problem caused me to uninstall the OpenXR Developer Tools on this PC and after the reinstall it doesn’t work any more. No error code it just brings up the welcome screen and then exits to the Windows 10 desktop. I suspect it is some files left over by the uninstall are inhibiting the reinstalled program.
Any help appreciated.

I’d get in touch with Microsoft’s OpenXR team, since that’s who is behind that tool. https://aka.ms/openxr

Thanks for that. I have already tried that but thankyou for the suggestion. Maybe I didn’t push hard enough. I will try again. I agree it is their problem.

Could you use the Feedback Hub app and “report a problem”? Put “OpenXR Developer Tools” in the summary line and select “Mixed Reality / Developer” for the category/subcategory, and finally under the last section do a “Start recording” and then reproduce the problem, then Stop recording. If you could submit that it would help us get the information we need to diagnose the problem.

With the latest updates to Windows 10 and/or MSFS2020 this peoblem has corrected itself