opengl's win9x problem, that works under win2k! this is weird!

well i was here programming for my program, well and i sent it to some
friends to test it…
well here works just fine! no problems, no depth problems, nothing that i
can see!

the only problem is that a friend of mine told me that the program was
wrong… far away objects seemed to overlapped the nearer objects… well i
have a far plane to clip objects that are in fog… in my computer under
win2k it works just fine, but finally i ended up running the program under
win98 & winME… well there i found the problems…

the problems are that it seems that i didnt enabled GL_DEPTH_TEST or that i
disabled Z writing, glDepthMask(GL_FALSE);

well the problem is that why doesnt it run the same as under win2k???
why does this problems appear under win98 & winME and not win2k???

its weird to see the objects that shouldnt appear on screen, thru the
objects that are on the screen…
for example if i have a Tree that should be on the other side of the
mountain, still i can see the top of the tree under win2k!!
the problem under win98 & winME is that even without reaching the tree’s
position, i can see all tree thru the mountain!!
also the FOG doesnt seem to apply to the trees… i have glEnable(GL_FOG) in
the routine but it seems it isnt!!!

well anyone know anything about this? i guess it cant be a opengl problem…
but im tired of looking to the code and trying stuff with no success… its
hard to see a OS **** up your work! =) when everything just fine, and u go
test it under other very similar OS and it doesnt work =)

could it be coz of z buffer or anything like this? 16-bit? 32.bit? any ideas
? anyone? please? =)

thanks in advance

do you use the same graphic hardware? I solved many “night-filling-error-not-finding”
problems by changing my tnt2 to a geforce


hey mcbastian
well the thing is that im trying to make it work on most of the hardware

this problem that i talk about happened on a p3 733 with a geforce 2… but i tried it on other computer with geforce2 and worked fine…

i finally found out that this problem happens on computers with win ME… win 98 now works fine on the machines i tested

anyway its weird… last night this didnt work on a machine i have here… today i tried the program again on same machine with no changes in the code and it worked just fine… go figure! will i ever understand computers eheh…

If you use gluPerspective, than your
parameter for the near clipping plane must
not be 0.0! Set it to e.g. 0.1.