opengl32.dll does not fully load , Annihilator 2

Hi All. A Voodoo 5 was too long for my case, so I purchased a Creative Labs Annihilator 2. Its the GForce2, 32 megs, DDR,AGP.
Worked real great for about a week. Q3, all my favorite games in 32 bit, all the GForce demos worked fine. Grove, Gardens, etc. 3D Benchmarks all good for my cpu.
I have HP6460, Cel 400, Win 98, 96 Megs, DX 7a, AGP 2 slot, 440BX motherboard, 230 watt power supply. Using the Creative drivers with Blaster Control, AGP Tweaker.
My problem, can not get the opengl HW driver to load or it loads but Windows and everything else does not recognize it.
Blaster Control tells me, Error 540, Open GL not accelerated , reinstall display drivers. All else is ok. Quake 3 says, cannot load openGL subsystem. WinTune says, you have software openGL only, install HW open GL driver from your HW vendor, also says I only have VGA graphics card.
I spent about 4 hrs on the ph with Creative Labs Tech Support. Reinstalled all HW, all drivers, card apps, directx, including monitor many times. Have searched registry, and windows system files for drivers, also any old voodoo drivers. No old drivers found.
Card is using IRQ 11, Direct 3D works fine, even 32 bit color ok. Card runs about half speed in D3D games, sort of like it was a geforce256. No other cards installed except for SB Live, IRQ 5
Even tried Nvidia ref drivers, but they wouldnt fully load opengl either. Defragged hard drive, did a full reg clean, changed slots, tried everything.
So to sum up, card installed, openGL worked great for a week, now openGL not working. Have also tried manually extracting and installing the 3 openGL drivers, the card uses.
Any ideas, I have not tried DLing the Q3 openGL extras. Creative said they usually did not work with there cards, and it would overwrite the creative drivers.
Going into the reg tomorrow, looking for broken links, duplicates, etc.
Q3 finds the openGL32.dll, says ok, but then gives error, cannot openGL subsystem. Wish it would explain why.
Thanks for any help.
Happy GL
Timothy Kelly

You have or I have the same problem as you.I have found no way to fix it.

Originally posted by mayo:
You have or I have the same problem as you.I have found no way to fix it.

We all (and we are getting to be many) have the same problem. I just tested a Voodoo 5 in my combo (Acus CUV4X, 733MHZ, 256Mb) and had all the OpenGl I neeeded. With the Clabs Geforce Pro and GeForce 2GTS and Guillemot 3DProphet II, no Sir, you’re not allowed to OpenGL here. It seems to be a problem with the most recent Detonator, and smeone has do do a thing about it. Hi Nvidia, what’s the problem? Are you killing OpenGl so DX8.0 is King of the Hill?


Hi All, Well after a reg clean, and doing some manual reg editing, I got the opengl working again about 3am last nite. Stayed up till 5am enjoying the speed boost. Then on bootup today, problem was back. Everything working but opengl. Still no windows error messages, and card works fine in D3d.
The problem seems to be.

  1. Windows or other SW, that use OpenGL can not tell the difference between software open GL and hardware openGL. So when it cant load the HW openGL it defaults to the software GL or is loading the software GL by default.
    Possible Solution: I simply deleted the MS software openGL renderer. Which was version 1.1, and was a couple of years old.
    Question. DO I have to have the software openGL renderer, for any HW open GL drivers to work?

  2. The card install and uninstall program is really bad coding. Seems like a rush job to get the card out to compete with other brands GFF2 cards.
    When you do an uninstall, it leaves everything in the registry, when you click on details. So you have to manually remove all the references in the registry to get a true uninstall.
    If not you have dead links, because installing again, will give you duplicate links, one pointing to something , and another pointing to nowhere.
    Solution: Driver fix, so uninstall really uninstalls. Or use an uninstaller program before you install the card.

  3. I deleted everything having anything to do with both the creative and the nvidia ref drivers, including all sw tweak panels, GF2 demos.

  4. Think the problem is in the way the card installs into the HK Current Users Key. Also 3D Mark 2000, cannot ID the chipset, even when openGL is working and I get about 3000 in the benchmarks, good for my 400 celery CPU. I printed out the inf file, so I could see what is supposed to go where.

I believe its all drivers and SW related, since for an entire week, all was great. Funny the T and L still seem to work, and the benchmarks even when the openGL does not kick in, are still the same or a little better than a GeForce256. But thats not what I paid $295.00 for. Time to try the Nvidia drivers again now that I have been reg cleaning and editing.
Getting this openGL is work, is a real pain in the butt. VooDoo sure seems to have much better drivers, and much better install and uninstall.
Thanks for replying.
Happy Sounds when this OpenGL works.
Timothy Kelly

I have that card on a p3 750 and an asus cuv4x and dont have a single problem with it. IM using the reference drivers from nvidia if that helps any, never bothered trying the creative one. Also you might try using some of the leaked drivers 5.32 I think are hte current leaked ones. Dont know if this post helps any.


Hi. All post help, because they give you ideas and let you know you are not the only one in OpenGL Hell.
I tried the 532 drivers, they erased all my openGL drivers of any kind, and didnt install any openGL at all.
The reg remove on this version of the drivers seems to work good. As I didnt have to manually remove anything in the reg.
Started over again with blaster control and creative drivers. Funny, the reflecting pool demo works, but others dont. Blaster Control still tells me openGL missing or corrupted, please reinstall.
Back to trying Nvidia 530 drivers and the display director.
Right now, I have a very expensive D3D doorstop. I am about ready to wipe all the HW keys and simply reinstall all the HW.
Happy Sounds
Timothy Kelly