ok, im new to this OpenGL thing. :slight_smile:

I have an ATI RAdeon 7000 and thats all i know. I dont know if i haev openGL or not what but all i know is somethign wont work.

I downloaded a game called clusterball and i really wanted to play it. It uses OpenGl. I run the game, it starts to work… It shows me the title page in a greenish color(thats not right) Than the game quits and an error appears…

3DGM Error:

err param: “invalid enumerant”

What the heck does this mean?! :stuck_out_tongue:

Please someone help me… If i need to update. how?!!

hope for a response fast as i am eager to play!

thanks in advance!!

Go to and try downloading and installing the latest drivers for your graphic card.

ill try that

im confused! what do i click to update an ATI 7000?

Well, for starters, you’ve got an “old” card- support’s going to be “fun” for you.

I’m going to assume you’ve got either 98 or XP at this point (If you’ve got Linux, you don’t need to do anything else, the drivers for your card are already in place…). There’s links for the legacy drivers that were the last released version- for XP, you need to click on the Radeon 7000 link under the heading “Not Supported:” on the Radeon Drivers page.
If you’ve got 98/ME, there’s an uncertified driver on the support page for the same- it SHOULD work for your card.

Now, on to your original problem…

“Invalid Enumerant” means that someone passed an enumeration value (Which is a whole number value associated with a programming symbol in the code to make it easier to remember what you’re asking for…) to a function call in OpenGL that the driver/library doesn’t understand. It’s an off and on sort of thing for a game developer to not poll for all of the capabilities of a card, or poll but not gracefully degrade as well as they ought to. It’s a dead certainty that the game’s asking for something that your current OpenGL driver set for the 7000 isn’t able to provide.

Now, having said this, a new driver set MAY fix the problem. It probably won’t. This is usually due to the code asking for something that just isn’t there and the card can’t do for you. If the driver update doesn’t fix things for you, you can try to see if adjusting the games graphics quality settings to see if they’re doing something “off” at the higher settings that impacts your card.

In any case, I’d be taking the problem up with the vendor of the game as it’s definitely a bug- whether or not you get a work around or fix the problem on your own. They shouldn’t be shipping code with this issue.

huh?! … lol sorry its just i… grr.

IS there anyway i can install opengl on my graphic card?

sorry if im not understnading.

You need to download an old driver that supports the Radeon 7000. I don’t know which one. Perhaps Catalyst 4.5 or something really old.
Everything before Radeon 9500 is too old is is no longer supported by Catalyst 6.10

“IS there anyway i can install opengl on my graphic card?”

The driver includes a GL driver specific for your card. That’s the only way.

ok i got the game working in color and everything. BUT IT IS SOOO SLOW!!! IT TAKES 10 mintues for the mouse to move an inch.

I tried clicking on settings so i can change the resolution and what not but the mouse would hardly move 5 inches before i got annoyed and quit altogether.

Is there a way to counter this?

Depends… If it’s what I’m thinking is going on, you’re not going to get there without getting a more modern card in the machine.

The drivers typically punt to software rendering or partial software rendering if something like Transform, Clipping, and Lighting (TCL) support’s missing from the card. This would make it SLLLLOOOOOWWWW on the rendering- which is what you’re apparently seeing.

Which game would you be trying to play with your current setup, might I ask?

If you’re talking about anything other than Quake3:Arena or a similar game of that era, you’re not going to ever get it working right for you- the card you have just doesn’t have what it takes to make the framerates playable.