OpenGL support in Windows 7 with 9600M GT Card

By now I have posted this on several threads on other boards. I’m hoping that one of them can come up with my solution :slight_smile:

I am running dual boot (Mac OS X 10.6 and Windows 7 x64) with the NVIDIA card 9600M GT.

There are large horizontal bars that keep flickering across the entire screen when I attempt to play a game that requires OpenGL. I tried downloading the most recent driver (as I have 185.75 for now, it came with the Boot Camp drivers on the Snow Leopard disk, and 195.62 are the most recent) but to no avail. IN SETUP it states “The NVIDIA Setup Program could not locate any drivers that are compatible with your current hardware. Setup will now exit.” I have the 9600M GT Card, and I selected the GeForce 9M series Windows 7 64 bit version off of the NVIDIA website. Does anybody have any clue to why that certain message keeps popping up? I would really appreciate the help!

Thanks, appreciate the support –


This may be helpful –

Processor: Intel® Core™2 Duo CPU T9600 @ 2.80GHz (2785 MHz)
Operating System: Windows 7 Professional, 64-bit
DirectX version: 10.0
GPU processor: GeForce 9600M GT
Driver version: 185.75
Stream processors: 32
Core clock: 393 MHz
Shader clock: 786 MHz
Memory clock: 700 MHz (1400 MHz data rate)
Memory interface: 128-bit
Total available graphics memory: 2163 MB
Dedicated video memory: 512 MB
System video memory: 0 MB
Shared system memory: 1651 MB
Video BIOS version:
IRQ: 23
Bus: PCI Express x1


nvCplUIR.dll 2.5.371.01 NVIDIA Control Panel
nvCpl.cpl 2.5.371.01 NVIDIA Control Panel Applet
nvCplUI.exe 2.5.371.01 NVIDIA Control Panel
nvViTvSR.dll NVIDIA Video and TV Server
nvViTvS.dll NVIDIA Video and TV Server
nvDispSR.dll NVIDIA Display Server
NVMCTRAY.DLL NVIDIA Media Center Library
nvDispS.dll NVIDIA Display Server
NVCPL.DLL NVIDIA Compatible Windows Vista Display driver, Version 185.75
nvGameSR.dll NVIDIA 3D Settings Server
nvGameS.dll NVIDIA 3D Settings Server

large horizontal bars that keep flickering across the entire screen

You mean as if vsync was disabled, like at the start of this video here : ?
In this case this is easily fixable by selecting “vertical sync : force on” in the Nvidia control panel.

Otherwise, maybe bootcamp gets in the way and prevent correct detection of your hardware with the newer driver, but I admit I don’t know anything about this.

Sorry, nope. I tried both having the application change the vsync and forced it on, but alas, my problem remains.

You think that bootcamp could be the problem? Perhaps I should end Boot Camp from the Task Manager, log out, log back in, and try to install? EDIT: Tried it, still error. :stuck_out_tongue: DOUBLE EDIT: The smirk wasn’t really where I was going with that emoticon. I wanted more of a sigh, really.