OpenGL problem with Quake 3 cannot solve. Help please.

First, I am using a TNT 2 Model 64 AGP card with 32mb onboard. I have a Jetway 542B Motherboard. 128mb ram, 400mhz AMD K6-2 along with the 6.50 nvidia drivers. I get a opengl error upon start up and I’ve emailed both Activision and IDSoftware many times and they are not replying to me. Here’s the exact problem I get as soon as I start up Quake 3:

QUAKE3 caused a divide error in module NVOPENGL.DLL at 015f:69625a23.
EAX=0007ff80 CS=015f EIP=69625a23 EFLGS=00010246
EBX=00c602b8 SS=0167 ESP=014fc1e4 EBP=00c17228
ECX=00000000 DS=0167 ESI=00c602b8 FS=2967
EDX=00000000 ES=0167 EDI=00000000 GS=4bee
Bytes at CS:EIP:
f7 f1 c1 e8 01 89 86 fc 29 00 00 85 c0 75 1d c7
Stack dump:
00c602b8 6961e005 00c602b8 00c5fd50 6960ff32 00c602b8 00000000 00000d00 00000000 00c17228 69614449 00000000 00c17228 00000d00 00c17168 00c5fddc

What chipset does your mobo have?

Some via based mobos have problems with openGL. I have an FIC va-503+, 400mhz k6-2 and a Hercules 3d prophet II mx 32mb and it wouldn’t run opengl.

My solution was to re-install the via 4-in-1 driver set and select “STANDARD” agp and NOT TURBO. I’m told that slows down your AGP bus and that makes opengl work for me.

I can now run Q3 based games no problem.

If your chipset is a a VIA this may work.

good luck

Nope, I’m using the ALi chipset.
Any other ideas?

Is there a patch for AGP and your ALi chipset? Do they have a website? Try them. Your mobo manufacturers site?
Patches…etc, etc.

See if your BIOS lets you slow down your AGP to 1x. I know you loose frame rates but it may give you the result I got with the via chipset.

Look for a website with your mobo as a thread.

Try :

lots of forums there.

have fun…

Live well.


Nope, can’t slow down AGP in any way…by the way I’m using AGP drivers Version 01.68e

Dunno if there’s update for that or not, if there is can you let me know?


well without knowing a few more things about your setup try this websites and see if you need to update your BIOS or drivers.

Your mobo:

your mobo chipset:

also ahve you tried to run opengl setup ?

You’ll find a few apps here at that will look at your gl setup and tell you if you need upgrades or not.

If all this fails you may try and reinstall your vidcards drivers. Uninstall it first , go in under safemode and uninstall your card and drivers. Then reinstall them and see.


I wasnt able to make my agp card run either for a while. Download Powerstrip 3 from . In the options menu under adapter information there is an option to change your agp speed. I think the ALi super 7 AGP is just unstable at 2x. My card worked fine after making this change. Good Luck

P.S. The latest ALi AGP driver is 1.69