OpenGl on Linux

Hello,

I just need to get Opengl working on Linux. I’m using Mepis/Debian/KDE with an Nvidia/Matrox Gforce2 mx400. How do I activate opengl support?

Thanks
dlbrody@verizon.net

google for glut 3.7 and install it if you haven’t already

glut looks after the window stuff for you

open an editor like Kate and your good to go

I’m using Fedora so your mileage may vary

goto Nehe or similar and grab a simple tut

open in your editor

on the command line try the following

gcc -o <output_file_name> <name_of_your_c_file> -lglut

don’t include the “<>”

if I’ve made an error one of the pros will be along to correct me :slight_smile:

cheers

If you just need ot to play OGL game sand stuff and you are using NVidia chips then just goto www.nvidia.com and hit “download drivers” and install the Nvidia drivers - that’ll install OGL as well.

If you need help with installation then got www.linuxquestions.org and search the forum or post again here.

Basically it is just:

  1. Start a terminal in KDE.
  2. type (without the quotes) “init 3”
  3. sh nvidia_installer_whatever
  4. go through the options.
  5. get back to KDE by typing “init 5”
  6. Then edit the x86 config file as per Nvidia’s txt file.
  7. Voila! OGL that is fully accelerated

<note if you are using Fedora core 2 you need the latest drivers or a new kernel that supports 8k stacks

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.