OpenGL not working with TNT2 M64


Here’s the situation. I have a AGP TNT2 based 32Meg SDRAm graphics card assembled by videoExcel. Supposedly it has to run games that are OPenGL based, but its not. When I try to run the Soldier of Fortune game it tell me that:

Could not initialise OpenGL rendering environment!
Make sure you have the latest drivers installed (GLSetup is recommended)
Make sure your desktop has more than 256 colours.

I have drivers installed that come from the CD that came with the card. I had only installed the card today. Before that I had Diamond Viper 550 that was also suppoose to support the OpenGL, but didnt. The games like Quake2 did nto run on OpenGL.

Please help me,


Click Start / Run.
Type “win.ini” (without quotes) and press OK.
Search for a line that says “DVA=0” (without quotes).
Add a semicolon ( before the DVA (The line should now look like this: “;DVA=0” (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.
Note that not everyone has this line, and if there is none you’ll have to try another solution.

i don’t have that line.

also have the latest detonator 3 drivers.

What kind of motherboard do you got?

Hey dont worry its not just your problem.
I have the exact same card except it is PCI not AGP. I had OpenGl working in Windows 98 but I just recently got Windows ME. After that I havn’t been able to get opengl to work…Except for Quake 3 Arena. I got that to work in 800x600. But it didnt work at first. The way i got it to work is this. First of all I changed my desktop resolution to 800x600 and my color to 16bit. Then I loaded up Quake 3 and went into system and changed a few things. First I changed the resolution to 800x600 and 16bit color (exactly the same as my destop settings). For some reason it worked. So maybe im not sure but maybe you have to have you desktop settings exactly the same as the game settings until nvidia comes out with a better solution. Quake 3 is the only game that i have “fidled” around with. Maybe you could tell me what games you are having problems with and if you cant fix it with the above solution then post what games you are haveing problems with. corrently i would just run the game in D3D but if it requires opengl then post the game. thanks a bunch.

but it was working in windows 98! i want to get it workingin windows 98, o at least to isolate the problem why it is not working.


I dont really get which windows you got.
Is it 98. Cause its real important.
If you got a win98 you really have to get it work. And if you doesnt got a VIA chipset
on your motherboard it really,really have to work.
So please give me some info!!

yes, i have windows 98. my motherboard is an ASUS P2B-F. Apparently there are updates for BIOS which I havnt installed yet. But that is my motherbaord. Let me know if your is similar and if you had problems with it.

Your config should work.

First of all try this
set your aperture size to 64mb(in bios).
set the transfer speed on the agp-bus to 1x
(download agp-wizard from creative).
stay in touch.

Sorry I dont know how much ram youve got
but aperture size should be about half of your ram-memory.

Ok listen I fixed my opengl promblem on Windows ME so this should almost definantly work for windows 98 and 95. Ok this is what i did i downloaded the latest videocard and drivers and the latest version of direct x. I installed direct x and then i installed the drivers.Then you go into display properties by right clicking on the desktop.
Then click on the settings tab. Then click advanced. Then click the Riva TNT2 tab. Then additional properties. Then i checked the allow dual planes extension to use local video memory. and i left the rest unchecked. Then i set the default color depth for textures to use desktop color depth.
Then i set the buffer flipping mode to auto-select. Then vertical sync to on by default. That should solve your problem if it doesnt then I dont know what to say.

OK, i fixed it. and to tell you the truth, this was probably the most ridiculos fix every encountered by me. i ran the glsetup utility from Although at first it told me that the drivers that I have are newer then the ones it can give to me, second time around I forced it to give me the driver that it had. And it worked after that!

So all it comes down to is just getting the right drivers. Unfortuntely for the company that assembled the card, the drivers that came with the card could not support OpenGL, at least in my installation of Windows 98.

Thank you for all your input,


Nice work. With your components you shouldnt
have any problem.

The most open gl problems occur on winNT,
win2k, winME, VIA chipset on your mobo,
Graphic card that doesnt fully support openGL.

In your case you have nor of this problems.

The only thing you should be aware of is the win ini (dva)line. It could occur whenever.
Especially on tnt and geforce cards.
Im not sure but it seems connected to real media players or quicktime.


Hi Thelv, Thank you, Thank you, Thank you.
Your fix of “;DVA=0” worked for me !!
I have : Riva TNT2 Ultra 32M, VIA chipset, 128M 133Mhz DRAM, PIII600e, Win98SE, DirectX7.0a, latest GLsetup drv.
I suddenly lost OpenGL ability in Descent 3 and Half-Life. Also my demo of Star Trek Voyager Elite Force would not run at all with an OpenGL error msg. Now they work fine.
I was about to reformat + reinstall Win98 and everything until I read your message. Thanks again !!

Hello Xed

Im just curious. Do you have installed the 4 in 1 Via drivers. I noticed youve got a Via chipset on your mobo.(only for research)
You own me an answer he he!


I have the TNT2 m64 card but could never get openGL to work. D3D runs fine. Every time I tried to run a game in openGL it would crash the computer and I’d have to reset. Emailed lots of people who weren’t too keen on replying.

Cheers to all the people who posted notes. I had to change my BIOS and put AGP to x1 and aperture size to 32mb. Is there any way I could get openGL running at AGPx2 and 64mb?If not how much slower is this method?

System Spec.
AMD K6-2 550MHz
Soyo 5eHM V1.2 Motherboard
ETEQ 4in1 drivers
128MB RAM (100MHz)
TNT2 M64 32MB


forgot to mention Win98 SE


I’m not sure what you mean by 4 in 1

But in Ctrl panel under System Devices I have -

VIA Power Management Controller
VIA Tech CPU to AGP Controller
VIA Tech PCI standard host CPU Bridge
VIA Tech PCI standard ISA Bridge
VIA Tech PCI to USB Universal Host Controller

and I have installed -
VIA DMA tool

Mobo mfr is Octek.

I’d be happy to check anything else if you want me to.