OpenGL issues with RedHat7.2

I have a voodoo5 5500 and rh7.2, and all OpenGL stuff runs, but its display is totally messed up.

The entire game screen seems to be stretching from the bottom left corner of my screen.

Having this issue with Tribes2 and to verify that it is not the game itself, tried tuxracer and the same issue happens.

( also has someone who is having the same issue with Quake 3.)

Any ideas?

(Running Xfree86 4.1 - default with rh7.2)

You can try to find a better driver. I do not know where but you can check out the Mesa and XFree86 sites.

A guess would be that is has something to do with resolution switching. If you put your desktop in 640x480 will tuxracer look OK ?

Unfortunately changing to display resolution did not resolve the issue for either Tuxracer or Tribes2. Get the same funky display, streaching from the bottom left corner to the center of the screen. There is no readable area, however you can click on the buttons that are there… I have tried this in all different display resolutions, (640x480 -1600x1200) and @ 8 16 and 24 bit… Any one else have any ideas…

The problem is that 3DFX is out of business and so it is up to any users to provide new drivers for them… I am using the standard drivers that came with RedHat 7.2

Thank you!!!


I think that the linux drivers was not made by 3DFX so new drivers will probably be available.
If you try some glide programs and they works OK should the problem be OpenGL specific. Probably the drivers but maybe can it be Mesa or X. You can try to do a search on rpmfind for new drivers.

If nothing else works do I think that you can use Mesa with glide drivers. I do not have any experience with Voodoo but check out the Mesa site.

I reinstalled Mesa 4.0, and I get the following error now when I attempt to run Tribes2 :

“Your 3D renderer (Mesa X11) does not appear to be configured for hardware acceleration”

Other games work such as Soldiers of Fortune (which uses OpenGL) however, it is SLOW as can be…

This is frustrating…but fun. lol =)

Any ideas?

On OpenGL’s website it mentions that you have to have ‘hardware acceleration drivers’ plus OpenGL 1.2 in order for things to work correctly. Unfortunately, the problem comes in as to where to find these ‘hardware acceleration drivers’ since the link they give you is no longer there…

I am open to any suggestions =). thanks for all your help so far!

on the windows xp topic there is a link to nvidia g force drivers follow it at the bottom of the first page u find yourself on there is a link to and it works

try it is there i have just accessed it through nvidia,s home page

Unfortunately, I don’t need windows drivers, and there are no linux drivers provided on for the Voodoo5.

Any further suggestions?