opengl in quincy

i’m trying to get into opengl programming, and the only ide i have is quincy2002. the problem is i can’t seem to get it to recognize the header files or the library files. i get these two weird errors first:
“C:\Quincy2k2\Mingw32\bin\gcc.exe -g -|C:\Quincy2k2\Mingw32\include -oc:\hello.o -c c:\hello.c” and
"“C:\Quincy2k2\Mingw32\bin\gcc.exe -o C:\hello.exe -LC:\Quincy2k2\Mingw32\lib C:\hello.o”

and then a whole bunch of errors saying stuff like “undefined glvertex()” etc, which i take to be caused by the headers and libraries not being read. anyone know anything about this? can opengl even be used in a quincy ide? thanx.

Quincy or not, gcc is the compiler being used and that’s what should matter.

Can you post a copy of the actual compile/link errors?

are you linking to the libraries?
this can be done either in the project settings or with
#pragma comment(lib, “opengl32.lib”)
the pragma may not work in gcc, I don’t know how well supported it is, but there should be an option in your build settings to link with the libraries.

i linked to the libraries in the build options menu.

what do you mean compile/link errors? you mean the ones below the ones i posted? well, there are quite a few and there is no way to copy the text to the clipboard, so to make things easier here is an image of the error text.

[This message has been edited by NightGiant (edited 02-14-2004).]

… and there is no way to copy the text to the clipboard,…

If your IDE does not let you do that, drop it, really. Learn to use it correctly or use Dev C++.

For your problem, gcc can’t find the GL and glut libs. Beware, they can be called xxx32 or xxx alone under windows. Check your C:\Quincy2k2\Mingw32\lib directory.

Remember to add under project options for linker settings, if like most IDE should be under something like that.
for gcc it is: -lopenGL32 -lglu32 -lglut32

is that the same as the command line options under build options? because the only project options are path and what kind of project it is.