Opengl hardware rendering fails

Video: MX440

I tried alot of things and most basic troubleshooting like reinstalling drivers after properly removing nviodia drivers, registries and anything I could get my hands on. Even after friesh install after there was nothing left of old drivers it wouldn’t work. Any application I run either runs in software rendring using opengl32.dll or fails to start because software rendering is out of the question. Any test for v1.2, 1.3, 1.4, 1.5, 2.0 fails.

I belive some other application that I have installed and havn’t uninstalled properly is somehow interfering with normal operation of nvidia opengl drivers. I KNOW drivers worked. But what happened?

I used OpenGL Extention Viewer to give you a hopefully clear picture of what’s happening:

this is the extension viewer report of the situation:

No Hardware support
You current desktop configuration DOES NOT support OpenGL Hardware Accelerated.

No compiled vertex array.
This may leads performance loss on some applications

No 8bit palette texture support.
This may leads performance loss on some old applications.

No multitexturing extension.
This may leads performance loss on some application.

No secondary color support.
Some applications may not render polygons correctly.

No S3TC compression support.
This may leads performances loss on some applications.

No Texture Edge Clamp extension.
This feature enables an important DX6 feature for texture mapping. Some programs may not renders texture correctly (black line on borders)

No vertex program extension found
This feature enables vertex programming (DX8 Vertex Shader) Some for actual or future OpenGL programs may requires this extension to run.

No Fragment program extension found.
This feature enables per pixel programming (DX9 Pixel Shader) Some for actual or future OpenGL programs may requires this extension to run.

Few texture units found.
This would slow down some applications using Fragment Program or extensive texture mapping.

looks like I posted in the wrong forum. sorry. I will repost in the proper forum.

If its a PNY card then the drivers that came with it are no good for OpenGL on XP. There’s also a more recent nVidia driver that has problems in 32 bit color mode, so try setting the display to 16 bit color before running the app.

P.S. It looks like you’re from a nearby town of asdf asdf. And to think that people say I’m just a lazy programmer is an insult to my name! :stuck_out_tongue:

Looks like you are using the 6177 Detonator Drivers which are very very old (at least 2-3 years old by now)

Try to get the latest Detonator (at least 6681) from the nVidia web site

Better, Get Driver Cleaner and removes all trace of previous driver, and then install the latest Detonator

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.