OpenGL graphical Glitches with UTNT2 and VIA apollo motherboard

hi ,

I own a generic Ultratnt2 with a asus Via apollo based motherboard, and so far whenever I try to run opengl games, they load up properly they dont crash, but I get these wierd graphical glitches , when a scene loads up everythings fine, as soon as you start moving, these black dots start appearing all over the walls. Since I am new to the Utnt2, I was wondering if I didnt set the proper openGL options or something, D3D works fine, I’ve got the lates detonator drivers. This problem exists with Sim, Halflife, Quake II.


Hmmm … dots appearing on everything is a common effect you get when you overclock a card too much, but i guess you haven’t done that, and that shouldn’t only affect the OpenGL based games. If you have an overclocking utility it may be worth to try to clock it down a little.

I have the same problem(except for the black dots, me its the Unreal logo when entering
a game(in Unreal Tournament)that is all
fuc*ed up). Also, images appear at a short distance, unlike D3D. I have a GeForce, with
the same MB chipset as you(Asus P3V4X).
Btw, having a GeForce,(with is kinda recent)
should I install the latest OpenGL drivers
or does my GeForce already has it?
Thanks in advance
Oh and for our problem, then its either
the 3D card(both made by nvidia) or VIA.
If you havent aleady, you could download your latest AGP update from
It helped me a lot(yet it still bugs)
And plz dont forget my question, its real important to me.

If you have the drivers from the cd you are probably not having the latest drivers, try updating them.

I have the same problem with Creative Riva TNT2U and I can’t solve the problem!!!
I’ve tried all the latest drivers, I tried Fast Trax from creative to underclock the board, and… nothing!!
I have a Elitegrup P6BXT-A+ motherboard with the last bios update with a PII-400MHz.
Nothing!!! Still the sam glitches in 3D gaming!