OpenGL(GLUT) on Linux vs. Winodoz 9X

I have been playing around with writing OpenGL programs on Linux.

I had compiled a few simple programs like open a openGL window and draw a simple object without any problems.

I tried a example program from, and got a display error when I tried to run it.

After some playing around with the code I found that removing GL_ALPHA from the display setup, I could get the program to run.

Also I have found that the examples run very slow as compaired to windozs.

Are these problem a linux video card driver problem? or a linux?

I have Red Hat 7.1 standard instalation, KDE desktop, 950 Mhz AMD, 128Meg’s RAM, ATI Rage turbo pro video card.


this seems strange.
normally, ATI rage pro are very weel recognized under Linux. I had an xpert play 98 before, and i had as weel the same result under Linux as under Windows. Why are you encouter these problems ? I don’t know now.
which xfree are you using ? do you use mesa or simply opengl and glut ?
Note that KDE first version was more slowly even if it was less sizing.

I think that you mean GLUT_ALPHA as mentioned in your earlier posts. This should not break your program. It can perhaps be some strange error with the tools?
Try to build from the command line with something like
g++ filename.cpp -lGL -lGLU -lglut

I also really recommend using X with 24 color depth as default. Perhaps can your errors be the result of 8 bit color depth?

[b]I think that you mean GLUT_ALPHA

Maybe, and this one require alpha bits in the frame buffer, something you almost never need (it is not related to alpha blending).

Most importantly, your card does not seem to be 3D accelerated under XFree, you were probably running the Mesa software implementation.

  1. you can check if you’re running Mesa by running ‘glxinfo’ and reading the vendor string

  2. your ‘turbo pro’ ATI card flavour seems to rely on a Mach64 chipset, which is not 3D accelerated, see status page :

[This message has been edited by zerodeux (edited 12-06-2001).]

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.