openGL gets stuck when window is selected?

Hi All. This is an odd issue. I can’t figure it out and have googled for a few hours to try to find similar issues. This happens on only my development computers. Other computers around the office here are not symptomatic.

In my application I am writing if I choose the window by clicking on the window itself the content stops updating. When going into the logs I get stuck on the first glBeing(GL_QUADS) call that I make after i select the window.

The exact same symptoms are seen when using glxgears. When I click directly on the gears bringing the window to the top it stops updating until i select another window.

The computer is a fully up-to-date Fedora 8.
Kernel =
X server = 1.3
Nvidia Driver (Installed from bin file): 180.29

Any ideas? I am at a loss right now.

Update: I forgot to add that the problem goes away for a few days (for both my program and glxgears) If I reboot or restart X. (ctrl-alt-backspace).

Have you tried to reconfigure the package xserver-xorg?

>$ sudo dpkg-reconfigure xserver-xorg

Weird. Been developing on NVidia/Linux for 8+ years on many NVidia GPUs and never seen this.

My guess is also that something is odd with your X server configuration. I’d sift /etc/X11/xorg.conf, and compare contents with another machine that you don’t see this problem on. Also compare GPUs and GPU driver versions. Sounds like some X optimization that’s just redrawing the window bitmap when it knows it couldn’t have been occluded. Like your app is never posting a refresh even or refresh events are getting ignored. SaveRestore, …been too many years since I did X devel but there was a name for that. Might also be a window manager thing too, though less likely. Flip to another and see.

Hi. Sorry I have been out of touch for so long. I can confirm that this is still occuring with various different driver versions:


The affected computers always have at least two monitors configured with xinerama which probabaly is a partial cause to the problem.

Right now I am using Ubuntu 8.04 x64 and am experiencing the same issues. I tried doing the reconfiguration of X, however I am using a Xorg.conf file generated by the nvidia-xconfig and nvidia-settings utilities. I do not know if this is partially responsible.