OpenGL fails with ATI Rage Mobility

I’ve now confirmed that all OpenGL applications do not work on my new Dell Inspiron 5000e which as an ATI Rage Mobility card. Dell says it’s not their problem and ATI says it’s Dells problem. Has anyone been able to run Open GL with this card on the IBM or other laptops. I love the 1600 X 1200 resolution and until the nVidia GeoForce comes out this is my only option. Anyone have suggestions as to how I could remedy this or actually talk to someone who could document and fix it?

Thank You, Kathleen Liston

I was able to get it to work … horribly but it worked … with my Inspiron 5000. But other than that I haven’t had any luck.

Sorry, Kathleen, I don’t have an answer to your problem; I have more-or-less the same problem. My machine is a Dell Inspiron 7000 with the Rage Mobility chip.

I’m doing some graphics development, and was very impressed with the hardware acceleration I got when I put up Microsoft’s DirectX 7. Subsequently I tried DirectX 8 and the acceleration went away. ATI says these chips are customized by the PC manufacturer and does not provide graphics drivers for them. Dell has downloadable drivers, 4 of them to be exact, but no information on what they are in detail or how they differ. The file names of two of them begin with the letters “gl”!

I am not pursuing the use of DirectX 8 because it has other problems as well. I would prefer to use OpenGL but do not know how to hook it in to the hardware acceleration of this chip. Can anyone help?

Kathleen, I spoke too soon. I now have graphics acceleration running on my Dell Inspiron 7000 with the ATI Rage Mobility card. Here’s what you should probably do.

Find and install either Microsoft’s DirectX 7 or DirectX 8 free product. You can get DirectX 8 on CD-ROM for about $10 from the Microsoft website. OpenGL requires it.

Download GLSetup. That’s an install over the web. See elsewhere in this website (or It a little over an hour.

That’s about it! But hardware acceleration seems to work only in 16-bit color mode (Control Panel/Display/Settings). That’s probably a bug; it should probably work in 32-bit color mode as well, but doesn’t. In addition, 256-color mode doesn’t seem to work anymore (if anyone’s interested).