OpenGL ES on Symbian 6.1 problem

i can’t get the emulator working with OpenGLES applications.

My setup:

  • series 60 SDK 1.2 for Symbian OS, Nokia Edition (downloaded from Nokia’s site)
  • OpenGL ES 1.0 for Nokia Series 60 (downloaded from Hybrids site)
  • VisualC++.NET

Windows XP

I can build and run the examples (from the SDK) on the emulator device. The OpenGL ES example builds ok, however when i run it from the emulator I get a “system error” dialogue on the emulator screen.
I tried to debug it from VisualC.NET. It looks the the error occurs after libGLES_CM.dll is beeing loaded (the .dll and the .lib are installed correctly). None of the code from the example is executed.

I also tried the OpenGL ES 1.1 version, same results.
The faq (from Hybrids OpenGLES package) mentions that the Nokia 7650 (this will be my actual test-phone) is supported, so this is not the problem…

what can be wrong?

Found the solution" VC6 solves the problem…


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.