OpenGL ES 2.0 does not support all APIs of 1.1?

I have a code for my old application for which I used OpenGL ES 1.1.
And I have a plan to build a new application with OpenGL ES 2.0.
A new circumstance support OpenGL ES 2.0.

I expected that every functoins in OpenGL ES 1.1 will be supported in 2.0.
But there is some functions that I can not find in 2.0 such as glPopMatrix()
, glPushMatrix(), glDisableClientState().

I refered the below document:
1.1 -> http://www.khronos.org/opengles/sdk/1.1/docs/man/
2.0 -> http://www.khronos.org/opengles/sdk/docs/man/

Should I build a new application with new 2.0 API ?
Can I use my code without any modification ?

OpenGL ES 2.0 is NOT backwards compatible with OpenGL ES 1.1. The entire fixed-function pipeline has been replaced with a programmable pipeline. This means that you can not run 1.1 code unmodified - you need to implement the parts of the fixed-function pipeline that you need yourself.

according to the specification of http://www.khronos.org/opengles/sdk/docs/man/
even a general functions such as glPushMatrix(), glPopMatrix(), glRotate() is not being supported.
Is that true ?

Yes, that is true. The matrix stack has been removed. You need to implement your own matrix routines for OpenGL ES 2.