OpenGL error in game


I recently installed Vista Business on my computer that previously used to run XP Pro and now Wolfenstein: Enemy Territory no longers works on it. The error message in the console runs like this:

ET 2.55 win-x86 May 27 2003
----- FS_Startup -----
Current search path:
C:\PROGRA~1\WOLFEN~1\etmain\pak0.pk3 (3725 files)
C:\PROGRA~1\WOLFEN~1\etmain\mp_bin.pk3 (4 files)

3729 files in pk3 files
execing default.cfg
couldn’t exec language.cfg
couldn’t exec autoexec.cfg
Hunk_Clear: reset the hunk ok
…detecting CPU, found AMD w/ 3DNow!
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\Windows\system32\opengl32.dll’ ): succeeded
…setting mode 4: 800 600 FS
…using desktop display depth of 32
…calling CDS: ok
…registered window class
…created window@0,0 (800x600)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 32, 24, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (4)
…setting mode 4: 800 600 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (800x600)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…calling LoadLibrary( ‘C:\Windows\system32\3dfxvgl.dll’ ): failed
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

Does anybody have any solutions to this problem?
Thank you.

Apparently Wolf:ET did not find an accelerated OpenGL pixelformat.
Probably you need to install the drivers from your video card vendor ?
What is your video card ?

Its a NVIDIA GeForce4 MX Integrated GPU (a nVIDIA GeForce4 MX 440 built into motherboard). Vista says that my drivers are updated. I also tried uninstalling it to get Windows to reload the video driver again, still same problem.

When I try to update the driver manually, through the nVidia site in the previous post, an error message comes up on the installation screen says that my OS is not windows which say “Setup detected that the operating system in use is not Windows. This setup progarm and its associated drivers are designed to run only on Windows. The installation will be terminated.”
I am choosing from the GeForce 4 series and the Windows XP/2000, as there is no choice for Vista.

I guess you are stuck then.
Maybe ask and ask again Nvidia for updated drivers…

But the goal is to make you buy a newer card … why did you buy Vista in the first place ??? For an old computer which was (probably) working well and much faster with XP ???

Some possible workarounds :
Maybe you can try moving away your config so that it goes back to default :

Under Vista you should be able to rely on the OpenGL version 1.4 emulated with Direct3D API.
Can you post what is reported by this tool (GL version, etc) :

Maybe wolfET does not detect reliably the compatibility mode, so you can try to allow wolfET to accept ‘software acceleration’ by setting this command to the autoexec.cfg (or another file, I do not remember well):
r_allowSoftwareGL “1”

Be sure to remplace a previous r_allowSoftwareGL if there was one.

This is what GLinfo said:

Driver version
Vendor Microsoft Corporation
Renderer GDI Generic
OpenGL version 1.1.0

Extension lists
Extensions GL_EXT_bgra
WGL extensions

Implementation specifics
Various limitations Max. texture size 1024 x 1024
Max. number of light sources 8
Max. number of clipping planes 6
Max. pixel map table size 65536
Max. display list nesting level 64
Max. evaluator order 30
Point size range 0.500 to 10.000
Point size granularity 0.125
Line width range 0.500 to 10.000
Line width granularity 0.125

Maximum stack depths Modelview matrix stack 32
Projection matrix stack 10
Texture matrix stack 10
Name stack 128
Attribute stack 16

Framebuffer properties Sub-pixel precision bits 3
Max. viewport size 16384 x 16384
Number of auxiliary buffers 0

Also, I moved my autoexec.cfg out and put in a new config with just the r_allowsoftwareGL “1” command, but it seems like Wolf doesnt recongize it. Still the same problems.

I am having the same problem and I am using XP. I have an NVidia 8800 GTS with the latest drivers. Enemy territory has encountered probs before with newer drivers not working and forcing you to roll back to an old driver. I am hopeful that there is another solution here.