OpenGL driver for ATI Mobility Radeon HD 4570...?

Hi everyone!

I’ve just bought a new laptop:

Dell Studio 15 - Windows Vista 64-bit
Intel® Core™2 Duo CPU P8600 @ 2.40GHz
4,00 GB RAM 800 MHz
ATI Mobility Radeon HD 4570, 512 MB
64-bit system
Resolution 1920x1080
DirectX 10

I’m using Rhino 4.0, 3D-modelling program. The program runs very slow. At Rhinos homepage it is stated that:

"New computers with Vista:

If you are looking to buy a new computer with Vista pre-loaded, be sure to check if an OpenGL driver is available for the video card you select. If it is not, Rhino’s display will likely be very slow."

I don’t suppose that i have an OpenGL driver installed right now. Does anyone know where to find one? I can’t find a driver at ATI’s homepage.

Get the non-laptop driver from ATIs homepage and then use the DhMod-Tool to make it possible to install the driver on laptops too.

More infos can be found on the DhMod website (that’s “”, funny thing “” is also available, though something very different…)


I’ve downloaded the DhMod-Tool, but I’m not sure about the driver. You said “non-laptop driver”, so you mean desktop driver at ?

When choosing desktop driver, do I in this case choose “Radeon HD 4500 Series”? Is it an OpenGL driver? I’ve tried to download that one, but it didn’t seem to work after I used the Modder tool and restarted.

Thanks for the help!

Yes you choose the desktop driver and since your card is a Radeon HD 4570 that’s the 4500 series. Every driver from nVidia and ATI include a DirectX and OpenGL driver. Only the pre-installed driver from Microsoft offers only DirectX support an no OpenGL support.

I don’t know if anything has changed, but back when i had a laptop with an ATI card, it was pretty simple:

Download the latest ATI driver. Install it, but then an error message interrupts it. Now the data is extracted to disk. Run DhMod-Tool to modify the inf-files. Go to the directory where the ATI driver was extracted to (and now modified by DhMod-Tool) and run it again. This time the driver installs successfully. Restart. Done.

Maybe you have not followed this procedure properly, the first time i was confused too.


I’ve tried it a couple of times but with no succes. I’ve also tried to delete the current driver and then installed the new one, but it seems like the new one doesn’t work at all. Mayde it’s the wrong driver. Here’s the link from where I got the driver:…amp;lang=Danish

Have you solved your problem? I have the same video card and I have some problems with other 3d-modeling software too. I’ve tried to do like Jan said but it seems to doesn’t work.