OpenGL doesn't work anymore

My opengl has always worked ok but since a short time my opengl cant be opend anymore. When i select it in games like quake2 or half-life it gives problems. I cant even look at AVI files anymore.

this is my hardware

General Information :
Model : 82845G/GL/GV/GE/PE Integrated Graphics Device
Bus Type : PCI
Manufacturer : Intel Corporation
Total Memory : 64 Mb
Processor : Intel® 82845G/GL Chip
Converter : Internal
Refresh Rate (min/max) : 60/100 Hz

and my openGL info

General Information :
Manufacturer : Microsoft Corporation
Version : 1.1.0
Renderer : GDI Generic
Acceleration : No, Software

Extensions :
GL_EXT_bgra : Yes
GL_EXT_paletted_texture : Yes

i have tried to uninstal my vga driver and reinstall but i doesn’t work.

>> I cant even look at AVI files anymore.

If it is related, check the “hardware acceleration” slider on the Display control panel, put it to maximum right “full acceleration”.

Originally posted by jellepunk:

Bus Type : PCI

This sounds odd. Did you installed any drivers latley or have “Windows Update” active?

thats weird since i have the exact same settings and i recently lost my open gl.

It isn’t with the hardware acceleration because is fully in use. anyone else has an idea?