OpenGL and the Myth of DirectX Backward Compatibility

Using Win 98 with two different nVidia cards I’ve been able to run a flight simulation program, ELITE GenView, that requires OpenGL. However, if I quit the program and attempt to rerun it, it crashes because it can’t open the OpenGL subsystem.

The two video cards tried are nVidia GeForce4 TI 4200 and nVidia GeForce2 MX 400.

I tried reinstalling Win98 which loaded with DirectX 4.0. The program in question then worked fine, start after start. I then installed DirectX 7.0a and again had no problems start after start. From DirectX 8.0 and up through 9.0, however, the same OpenGL problems kept the program from reopening.

What’s puzzling is that I don’t know what DirectX has to do with OpenGL and further, that the newer DirectX releases are supposed to be backward compatible.

The following language is copied from Microsoft’s DirectX FAQ:

  1. Backward compatibility is a key feature of DirectX.

  2. The DirectX 9.0 runtime includes transparent support and backward compatibility for all previous versions of DirectX.

Can anyone take these observations any further so as to resolve the nagging OpenGL problems plaguing this forum?

having the same problem with x-plane. They used to have a patch to brute force the system to work, but they have taken it off the site, or at least I cant find it anymore

I’ve been led to believe by the people at ELITE that they’ve never heard of the problem, and that it’s unique to my system, Win98.

Try downloading the latest video card drivers for your cards at the manufactuer’s sites. So for NVidia, . The latest video card drivers also come with the latest directx drivers and OpenGL drivers.

I feel completely lost. There are so many people with opengl problems, and nvidia problems but no definitive solutions. I have done everything I was supposed to do to install nvidea geforce 2 mx400 onto pentium3 with win2k, but I cannot even get the opengl screensavers to work without hanging the system. If somebody knows what to do please tell me, cos I am contemplating returning to an abacus.

The suggestion to use the latest drivers is widely thought to be a supposed fixall to problems. My experience, however, is that habitually upgrading to the latest and greatest is frought with danger.

It was upgrading to the newer versions of DirectX followed by using the latest video card drivers that messed me up in the first place.

For what it’s worth, I share the sentiment of DaleP, above, regarding problems without solutions.

Well, the newer version of DirectX (if you mean 9.0) was in beta a while ago and probably still has bugs in it. But what does a newer version have of DirectX have to do with OpenGL?

Anyways, you are right that the solution is throw around quite a bit. However, a lot of people that took that advice have solved the “Could not load OpenGL subsystem” on games like Medal of Honor and Return to Castle Wolf. But you’re right, this may not be the solution to the problem here, but it is something worth trying.

The reason is that NVidia card drivers that came with WinXP were horrible and sometimes OpenGL didnt’ even load up. I programmed a spinning cube in OpenGL and i bought XP when it came out. Suddenly the FPS of that program dropped to a crawling rate. I updated drivers and everything was back to normal (maybe even better).

Your comments are noted and I partially agree with you.

  • Halcyon

Edit: I forgot to mention that most of these cards that have these OpenGL errors are state of the art Nvidia or ATI cards. The drivers that come with windows are for OpenGL 1.1 (they stopped updated when directx came out … obviously since ogl is their competition). So even WinXP has drivers for OpenGL 1.1. By telling you to get new video card drivers, I’m not telling you your video card is messed up. With all the video card drivers, the manufacturers pack their own OpenGL drivers that are updated and meant for the card. Each manufacturer supports some extentions that only work on their cards. With generic drivers, you have no access to them. Oh yeah, and OpenGL 1.4 is the standard now and OpenGL 2.0 is soon to come out.

[This message has been edited by Halcyon (edited 01-08-2003).]

Well, the truth of the matter is that I’ve tried the latest nVidia drivers, 41.09, as well as the latest by Gainward, the card’s manufacturer, 29.80.

It was only reverting back to DirectX 7.0a that things worked. What DirectX has to do with OpenGL is another story. The point is, I achieved some dubious satisfaction by going backwards, not forwards. Needless to say, this is annoying because while using 7.0a I’m precluded from using software that requires 8.1 or higher.

I wonder if this is another microsoft ploy against OpenGL .

Ok all here is my problem I just bought a geForce4 MX(440)-SE 64MB SDR. I am a gamer and I love online gaming well not no more when I load a game that requires MicroBlow DirectX the screen goes blank but the CPU is still running so in order to get back to my desktop I have to <Ctrl> + <Esc>. Now I have contact support from the maker of the card and they tell me it is a Dual Boot problem so I remove the Dual Boot format and Reinstall FK it still does not work so now I am told to make sure I am loading the right drivers while I did FK still does not work so now support wants me to install the drivers from Nvidia so I do F**K it still does not work. Can anyone help me with this problem?

P.S. And they say Nvidia is better than ATI Bull****…

Thank You,
Pissed Off

you need to to access your computer in safe mode. once your in safe mofe you need to get to your device manager. once there look at your video cards , delete all the extras except for the video card driver your using.
this only works in safe mode,because you will not see the extra drivers loaded in regular mode.
restart your computer and try again.
FYI- when you update your video card you need to remove all the orginal drivers from your PC or your computer will have conflicts like this , when it trys to run certain programs , it gets confused between what it has to choose from.
it worked for me.

For syscom :
your card may not be compatible with your mother board.try your card on a different PC, ive seen this with 2 cards a banshie Creative labs card and a TNT card. they are older yeah , but same conceptapplies here.

you may not have a strong enough power supply. all video cards pull a certain amount of voltage from the power supply .
make sure you have a 400 Watt PS if you have an athlon , or a p4 , if not , its probably your problem.

another thought is maybe the AGP slot is bad on your mother board. if you slid it in wrong or pryied the old one out.

Did you ground your self out before touching the vid card???
if not all it takes is a static shock . did you install it on carpet? shame on you if you did . Ive blown too many componets on carpet .

could just be a diode on the card thats all it takes.
good luck what ever it is , i’m just trying to throw out ideas.

dan w Did all of that if you read up you will see I even reinstalled Windows 98 SE and still the same problem here is what support tells me at inno3D:

1st Time
Dear Kevin,

Probably it is due to driver crash with your previous graphic card.
Please try the following:

  1. Remove all vga drivers in safe mode (recent or previous graphic
    reboot and re-install the driver.
  2. Perform a clean installation of Windows system, in most case,the
    problemcan be solved.

Best regards,
Technical Support, InnoVISION

2nd Time:

Dear Kevin,

For dual boot system, it will be a little bit trouble.
For win98se, make sure you didint install the driver wrong!
WinXP is a more stable system, so it should have no problem than
Please also check your system BIOS setting too.

Best regards,

Technical Support, InnoVISION

3rd Time:

Dear Kevin,

Try update your motherboard chipset driver for AGP. In bios, lower down the performance setting of AGP. Yes, it is our card, but we can’t control the hardware and software combination from users, there must have hardware /software incompatibility problem even with a very
well-known brand like ASUS.

Best regards,

Technical Support, InnoVISION

I have allready done all of this and still it does not work. That is a bunch of crap…

what chip set are you using?
AMD , Intel?
whats the voltage on the PS?

just a thought ,when i bought my GForce 4 card , when they first came out. the drivers for it were not complete , so they sold them to us the consumer with Gforce 3 drivers.
i have yet to update to gf4 drvs.
this is a reach , but you might want to dwnld the gf3 drvs and try again.

dan w The funny thing is on the same system Dual Booting I Boot Windows XP and everything works fine. It just will not work with Windows 98 and the other funny thing is the card works fine untill you go into Full Screen Mode with Windows 98.

dan w Here is my system

Soyo SY-K7VTA Pro
AMD XP 2100+
400 Watt PS
(2)120 GB Western Digital

yeah that is pretty weird,
Do you think it’s possible that the drivers or the Direct X loaded is only compatible with ME/XP and not 98?

do you have alot of devices on your desktop PC? are all the interupts used up on 98?

No because I had an ATI Magnum in my machine and every one was telling me how great the Nvidia cards were so I gave it a try and this is what I get.

wow thats strange , i’m running
win 98SE
soyo Dragon
and Athlon 1800XP
no problem, we have almost the same set up .
but i do run everything USB soyo makes it easy that way . only card in my PCI slots is a Layla Echo Sound card . which is disabled on my normal profile , i use the onboard sound.