When I try to run some programs, I get the following two lines of error message and the programs quit. Whether anyone can help fix this problem? Thanks.

The OPENGL32.DLL file is
linked to missing export GDI32.DLL:GdiSwapBuffers.


Hi same problem (see post opengl and CivIII game 01/26/02) on my sons computer. what type pc and video card and what games? He thought he might have deleted some share files when uninstalling software. How about you?

I checked your message. My computer is Micron 600 MHz, Pentium-III and has a NVidia Riva TNT2 Video card. I do not know about deleting any shared files (but might have happen during some unistalls). I just tried to install a small science related molecular display program and it does not work. I downloaded the new drivers from NVidia website but it does not help. And the program support people are also puzzled! Let us see if someone gives any suggestion.

I forgot to mention that it is Windows-98 and two years and 4 months old.

You have the same video card I have on my computer. I am still using the old drivers. His game works on my machine. Are there any other programs where the error is displayed? Does your molecular display program start before the error? His error is displayed before the game even gets started

Okay here’s some more info to compare. I’m running the same video card. The Bios I’m using on the card is version 2.05.04 My OpenGl,Display, and DirectDraw Driver is version Again I have done no upgrading to the drivers. You can find this info by right clicking on the desktop, clicking properties then choosing the settings tab. From there choose Advanced and then the Riva Tnt 2 Tab. Here is the Bios and Driver info. My card has 32 Megs ram. Under Additional Properties select the OPenGL tab. My setup has the box checked to enable buffer region extensions. My direct 3D setting tab shows for mipmapping (top to bottom) 0, bilinear, and Best image Quality. The box for enabling anti-aliasing in hardware is
UNCHECKED. Maybe some of this can help you. Maybe the OLDER drivers (not NEWER) are the answer. Remember NEWER isn’t always BETTER!! Let me Know

The OPENGL32.DLL file is
linked to missing export GDI32.DLL:GdiSwapBuffers.

Somehow you got an old version of the OpenGL32.dll.
Replace the dll with an up-to-date version and you are fine.

my opengl32.dll file is 4yrs old and the system works fine

Yeah except that your OpenGL32.dll is missing the GDISwapBuffer function which was introduced in a later version…

Reply toNothing. Is that why the game works on my pc (4YRs old) and not my sons (4yrs + 3mos.). Yet Chandra here has a newer pc than both of us. Or is it the version of the WIN98 second edition?

We’re gonna give the opengl32.dll,gdi.exe and thegdi.dll files a try. My files are about 3 yrs old(4/99create date) . My son’s files are almost 4 yrs old(4/98create date). There are file size differences. He also is WIN98 and mine is Win98SE(Second Edition). We purchased the PCs 3mo apart from Gateway. I’ll let you know if this works. Thanks for the Idea Nothing. I’m e-mailing him the files now.
Stay tuned

The Bios in my video card is version 2.05.01. My DirectDraw Driver is version 4.0.1. I have upgraded only the openGL (so, Nothing’s comments are too late and did not work). My OpenGL tab also has the box checked for enable buffer region extensions and Direct3D settings show mipmaping for Best image quality (but I do not see other information as ‘(top to bottom) 0, bilinear’. Also I do not see any box for enabling anti-aliasing.
The program does not start at all. First thing that happens is this error message comes and another small window with error message with the program name saying “A device attached to the system is not functioning” and that is the end of it.

My son loaded up the opengl32.dll file today. There is about 100kb differerence between the Win98 and Win98 SE version. I had to snail mail it to him because his MSN Network was down and would not accept the file. (THANKS MICROSOFT!!!). Anyway first shot and it worked. He just needed the newer Opengl32.dll file. But we also had upgraded his video card. The bios on your card and other drivers are older than mine on my system. What is the date and file size on your opengl32.dll file?
Mine is 737kb from 4/23/99. It’s in my C:/windows/system directory. I also sent him a newer version of a GDI.exe and GDI32.DLL if it was needed. He only needed the Opengl32.dll and his game came up. Let me Know if this helps