openCL compilation problem

Hello
I am new to openCL. Compiled a opensource raytrace engine dynamic libs and a small .exe including opencl , while debugging the .exe, It fails and here is the stack trace from windbg (It seemed a driver problem to me, I tried with 26.20 and 27.20 version of Intel VGA drivers also IntelSDK is insalled )

0:000> k
Child-SP          RetAddr           Call Site
00 00000079`637896c0 00007ffe`a9aea4f3 igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x144d33
01 00000079`6378a4c0 00007ffe`a9ae7ed5 igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x14a7e3
02 00000079`6378a630 00007ffe`a9aeaf6b igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x1481c5
03 00000079`6378a880 00007ffe`aa1b8169 igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x14b25b
04 00000079`6378a900 00007ffe`aa1b82f3 igc64!getJITVersion+0x494de9
05 00000079`6378a9f0 00007ffe`aa1b84fd igc64!getJITVersion+0x494f73
06 00000079`6378aa20 00007ffe`aa1b7b00 igc64!getJITVersion+0x49517d
07 00000079`6378ab10 00007ffe`a99bd00e igc64!getJITVersion+0x494780
08 00000079`6378ab50 00007ffe`a99bd1f7 igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x1d2fe
09 00000079`6378aec0 00007ffe`a994f141 igc64!GTPIN_IGC_OCL_UpdateKernelInfo+0x1d4e7
0a 00000079`6378aef0 00007ffe`a995e2b6 igc64+0x5f141
0b 00000079`6378bb80 00007ffe`a995e4dc igc64!CIFCreateMain+0x1116
0c 00000079`6378d210 00007ffe`957b7472 igc64!CIFCreateMain+0x133c
0d 00000079`6378d270 00007ffe`957afecd igdrcl64!clGetGLContextInfoKHR+0x24132
0e 00000079`6378d2e0 00007ffe`9568119c igdrcl64!clGetGLContextInfoKHR+0x1cb8d
0f 00000079`6378d3e0 00007ffe`9562f583 igdrcl64!GTPin_Init+0x3bf7c
*** WARNING: Unable to verify checksum for D:\brlcad-7.28.0\brlcad-7.28.0\openCL_acik\Debug\bin\librt.dll
10 00000079`6378d7f0 00007ffe`6021327e igdrcl64!clBuildProgram+0x7a3
11 00000079`6378d9d0 00007ffe`6020e1a2 librt!clt_get_program+0x33e [d:\brlcad-7.28.0\brlcad-7.28.0\src\librt\primitives\primitive_util.c @ 578] 
*** WARNING: Unable to verify checksum for rt.exe
12 00000079`6378e310 00007ff6`4f01b1e2 librt!clt_init+0x2a2 [d:\brlcad-7.28.0\brlcad-7.28.0\src\librt\primitives\primitive_util.c @ 671] 
13 00000079`6378ec70 00007ff6`4f048a94 rt!main+0x8e2 [d:\brlcad-7.28.0\brlcad-7.28.0\src\rt\main.c @ 319] 
14 00000079`6378f860 00007ff6`4f04897e rt!invoke_main+0x34 [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 79] 
15 00000079`6378f8a0 00007ff6`4f04883e rt!__scrt_common_main_seh+0x12e [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 288] 
16 00000079`6378f910 00007ff6`4f048b29 rt!__scrt_common_main+0xe [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 331] 
17 00000079`6378f940 00007fff`04af7034 rt!mainCRTStartup+0x9 [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_main.cpp @ 17] 
18 00000079`6378f970 00007fff`04da2651 KERNEL32!BaseThreadInitThunk+0x14
19 00000079`6378f9a0 00000000`00000000 ntdll!RtlUserThreadStart+0x21

I also tried with CUDA but It did not help much .Any help would be great… :sleepy::sleepy: