Open GL with Borland C++ 5.01 **HELP**!!!

I would be =very= grateful if anyone could help me here!

I have Borland C++ 5.01 and would like to program using Open GL…but: it doesn’t seem to be working!

I have put the header files (GL.h, GLU.h, GLUT.h) in ‘INCLUDE\GL’ and the library files in both ‘LIB’ and ‘LIB\GL’…and tried to complie a sample program. I get a ‘Unresolved External’ error for each Open GL command used, so obviously I’ve done something wrong!

I’m not a programming beginner - just new to Open GL.

Forward thanks for any replies – Jon Nolan

You need to explicitely add the OpenGL32.lib and GLU32.lib files to the project.

FYI, “Unresolved External Errors” almost always mean that you need to add a lib file to your project.


Are you linking the glut32.lib???
Do you have the version of glut for borland?

The only things you need to do is put the glut.h in the include path of the compiler, and add the glut.lib to your linked libraries.

if you need GLUT for boland, get it from

Does this sample program involve using textures?

I think you need an updated version of glu.h if you’re using Borland C++ 5.01. I use 5.02 myself, and got something similar whenever I used glGenTextures() and glBindTexture()…but when I updated my glu.h header file, that fixed my problem.

Ah, thank you all!

Yes, it =was= a texture example…and your advice worked a treat! Again, thank you!

Thank you all for your replies!

It =was= a texture sample program, and thanks to you, it now works. Again, thank you!

No prob…come to think of it though, I believe that was gl.h, not glu.h that needed updating…oh well. Here’s a site for you to check out:

Here, it shows you how to use, and set up, the OpenGL API with Borland C++…the directions for setting it up are for 4.x–I think–and command prompt, but I’ve gotten his instructions to work on 5.02.

The problem you were having isn’t uncommon, however. I’ve seen people asking the same thing–or something similar–when they’re using Borland’s compiler. To tell you the truth, I just posted a reply quite similar to this one a few minutes ago, but on a different thread =)