Oni, Voodoo1, software mode

I’m trying to get Oni to run on my PC, but OpenGL comes up in software mode even though I have a Voodoo1 board installed. I’ve checked by hooking the monitor up to the normal video card (without passthrough) and to the 3D card, and the signal really is coming from the normal card. Any ideas for how can I get OpenGL to use the hardware?

Some notes:

The Voodoo1 board is a Diamond Monster 3D, the system is a 266 MHz P2 with 64M RAM running Win95.

Win95 isn’t officially supported for Oni, but since the readme file has some notes about it, I have hopes it will run anyway. Similarly, I’ve seen comments about how special coding is needed to use 3D-only cards, but the readme file has notes about them, too.

I’ve been able to run Quake 3, so the problem isn’t just with OpenGL, it must be something specific to Oni.

I’ve tried using both the old IDC driver I used for Q3 and the new MDC driver that GLSetup installs for Voodoo1.

If nothing else, I’d like to be able to see which drivers OpenGL thinks it has installed, anybody know where I can find that, in the registry or wherever?

I figured it out already, but the solution isn’t one I’ve seen described anywhere, so I thought I’d post it for reference.

Inspired by what an article said about replacement drivers, and having read somewhere that 3dfx cards can’t run as normal ICDs, I tried replacing the normal Windows OpenGL (OpenGL32.DLL) with the 3dfx OpenGL driver (3dfxVGL.DLL) … that is, I renamed them so the 3dfx one was named OpenGL32.DLL. I’d checked that it exported similar-looking functions, and in fact it worked. So, I am happy.

Here’s the article I mentioned.