Offscreen openCL device - no GPU


I don’t know if “offscreen” is the right term but here is my problem :
If I run my program on a mac mini with a screen connected on his display port, I can use the GPU device to do my OpenCL computing, but if I run the same program without any screen connected (i.e. from an SSH session) the GPU device is not detected.

Is it a normal issue? How may I use the GPU in this kind of configuration? Indeed I would like to do some OpenCL GPU computation on a server grid (without any screen).

Thanks a lot for any help. I am really stucked.

I noticed that I can use the GPU if I log in with a local admin user, but not if I log in with a network user.
Is there any way to grant access to a network user to the GPU ?
Thanks a lot.

I’ve run into this bug as well. You have to have the window manager up and running to get a graphics context to use OpenCL on Mac OS X 10.6.

I have the same question. I posted this question on stackoverflow: … ely-on-mac

The fact root can ssh in and use OpenCL implies that there there could be some permission change that would allow ordinary users to access the GPU. I would like to know if that is possible.

The issue on the mac is whether there is a monitor attached, not whether the user is logged in. Any user can log in via ssh if the GUI is up and run OpenCL on the GPU as far as I remember. The problem is if you boot the machine headless.