NVIDIA_kernel install: Unresolved symbols

I am trying to install the nVidia tarred downloads and the ‘make’ is finishing with an Error 1 and the notice:

depmod: Unresolved symbols in

This is not the first time I’ve had this problem. I was trying to modify a driver for a radio card and when I would try to insmod the module, I got similar errors. In fact the same error for the module for the radio card shows up before the NVdriver:

Unresolved symbols in

I have posted elsewhere about this problem with some temporary results, but I am going to have fix it once and for all if I am going to use this nVidia driver. Here is that discussion:

Does anybody have any idea what is going on? Any and all tips and clues would be appreciated.


The README included with the NVIDIA_GLX download says:

If you receive errors
about unresolved symbols, then the kernel module has most likely been
built using header files for a different kernel revision than what
you are running. You can explicitly control what kernel header files
are used by building NVdriver from the NVIDIA_kernel tar file with:
‘make install SYSINCLUDE=/path/to/kernel/headers’.

Assuming this is my problem, how would I decide which headers to use?

This is not opengl related, but anyway…

try to use D_KERNEL on your gcc command, it mays help.

maybe, too… you may have recompiled your linux kernel, and so you may have made change on it… that your nvdriver doesn’t like.

The README included with the NVIDIA_GLX download says: …

This not seems to be the source of your problem. However I don’t know what are your competencies under Linux… I just think you begin on it.

If you got a precompiled kernel from red hat do they also has rpms with the matching sources. I do not remember if the headers and source files is in one big rpm. When you update your system with up2date will also the source files be updated.

I think my kernel may be my problem. When I get a precompiled kernel using the Update Manager for my Red Hat 7.3 installation, is it configured to my system? I’m worried that I may have damaged my configuration somehow using the Linux Kernel Configurator, which is graphical interface to set the .config file. I"m worried that if I update the kernel, it may be based on a bad configuration file. If I update my kernel, is it correct to assume the update will correct any errors in the configuration of the old kernel?

I have a Mandrake 8.2, but that’s a merge of Mandrake 8, 8.2 and some 7 … with the rpm database not uptodate… This is due to that i had to optimize all my system: your kernel: remove all your Redhat kernel which (if it’s like mdk) includes many things useless and forgot what you really need.
Then, you may have many problem with module dependencies, or bad kernel version for installing NVidia… so, use only (that’s the best way) sources to compile.

This is the way it’s got to be !
(coal chamber).

I would not worry about that the configuration may be damaged. Does not the configuration tool let you set some values that is written to the sources so when you build the new kernel will it has the changed values?

The problem is more likely that the kernel used does not match with the sources and headers installed.

The solution to this problem was in my /var/log/messages file:

<host> kernel: nvidia: Can’t find an IRQ for your NVIDIA card!
<host> kernel: nvidia: Please check your BIOS settings.
<host> kernel: nvidia: [Plug & Play OS ] should be set to NO
<host> kernel: nvidia: [Assign IRQ to VGA] should be set to YES
<host> kernel: nvidia: loading NVIDIA NVdriver Kernel Module

Changing my BIOS setting for [Assign IRQ to VGA] to YES solved the problem.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.