nVidia driver 1.0 - 6111 problems

Ever since I installed the nVidia linux driver version 1.0-6111, I’ve been having some weird issues.

I’ve noticed some of the following things occuring, but they do not occur consistently. They seem to be random, but fairly frequent.

[ul][li]Crashing of other apps such as firefox or gaim when starting an OpenGL app[]Segmentation faults when starting OpenGL apps. Usually if this happens once, it starts up just by trying to run it again[]Rebooting my system. (Only happened a couple of times, but very annoying)[]Applications like firefox and gaim not starting after running an OpenGL app. (If I run them from the command line it shows that they are getting segfaults)[]Shutting down WindowMaker after running OpenGL apps causes errors when trying to go back to GDM[/ul][/li]I’m using Slackware 10.0, and WindowMaker. My card is a GeForce2/MX. Has anyone else experienced any of these issues? Should I install an older driver or newer beta drivers, and if so, which ones?
When I installed the drivers it did warn something about the rivafb module, but doing an lsmod shows me that that module isn’t loaded so it shouldn’t cause problems right? Or is there something else I need to do with the rivafb module?

Most likely its a module called rivafb(not sure wheter i spelled it right), so you should remove that module from your kernel source, and recompile it.
Greetz Hylke

Thanks, I’ll try that out and see how it goes.

Didn’t seem to work. About 5 minutes after rebooting with the recompiled kernel, starting my OpenGL app caused me to reboot. I tried compiling it again removing all of the other framebuffer modules as well, but it still didn’t fix anything.

Did I remove the right module? Using make xconfig, I went to Console->Frame Buffer. I looked around in the options a bit, but didn’t see anything else that was called Riva. Since the module was named rivafb, I assumed the frame buffer (fb) was the right place to remove it…

What i did was:
cd /usr/src/linux
Then i typed(as root)
make menuconfig
Console Driver -> Framebuffer Support -> hit 2 times(if its compiled as a module) spacebar on nVidia Riva Support -> Exit -> Exit -> Exit -> Yes
make dep
Greetz Hylke

Yep… that’s basically what I did too, except I used make xconfig, and after make dep, I did a make bzImage, copied bzImage to /boot, edited my lilo.conf so that I had another boot option to use bzImage, ran lilo, rebooted, selected my new boot option…

Are you using XFree or XOrg and which kernel 2.4 or 2.6 - I am running Fedora Core 2 (Athlon XP, P4, Xeon, and AMD64) at work and Gentoo (AMD64) at home all using 2.6 kernel with Xorg - no problems with nv 6111 drivers.

That won’t help you much probably so post your X /var/log file after it crashes next…

Something does seem wrong here… please send an email to linux-bugs@nvidia.com with a description of the problem. And please attach an output of /usr/bin/nvidia-bug-report.sh

To run that:

cd /tmp
and then attach /tmp/nvidia-bug-report.log to the email you send to linux-bugs@nvidia.com


I’m using XOrg and the 2.4.26 kernel. It’s also a pretty fresh install of Slackware. I reformatted recently when I rebuilt some of my hardware.

I tried sending a bug report once, but got a returned mail failure… I’ll try again, though. Maybe I had a typo in my e-mail address or something.

I’m not at home right now, but I’ll check my logs tonight when it crashes again… :slight_smile:

Edit: Checked my sent mail… I had tried sending to linux-bug@nvidia.com. Where’d my S go? Doh!


You could also try the latest available drivers from nvidia.com. (Version 1.0-6629) This will be the first thing they’ll tell you after contacting them.
Good Luck.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.