Nvemulate, Vista

Anyone tried nvemulate.exe on Vista 32 bit?
I want it to dump the compiled shaders. I believe that either UAC is blocking nvemulate.exe from changing the registry.
If I knew what needs to be changed in the registry, I would do it myself.

Why not shutoff UAC altogether, or at least shut it off for the time you need to work with nvemulate?

for 32bit windows.


for 64bit windows you have to do this like above for the 64bit stuff and in the following key for the 32bit stuff:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NVIDIA Corporation\Global\OpenGL\Debug]
....same as above

I thought I did shutdown UAC. I’m not getting warnings anymore.
I checked the registry and nvemulate is able to change the values.

was actually 0 and even if I change it to 7, it makes no difference.
AFAIK, the shaders should be dumped into the same folder path as my exe.

Anymore ideas? Maybe the drivers have been broken by Dell. This is a laptop and I did install Vista myself (using dell DVD) and all the drivers (from Dell’s site)

When I ran Vista some months back, I had the same problem. Only I was using “OpenGL Extension Viewer” to modify the registry instead of nvemulate. It had no effect. The forceware vista driver didn’t pay attention to that registry value. I guess it hasn’t been corrected…

Thanks for confirming, Nicolai.
At least I have the cgc offline compiler to work with.

i use the regisrty entries myself on vista and vista x64 and the driver dumps the shaders.

did you set the WriteProgramObjectSource DWORD value to 1?

and beware, on 64bit windows you have to set the values for the 32 and 64bit environments seperately.

It is Vista 32 bit.
8F773984 =0 <—if anyone knows what this is for, let me know.
Renderer =0
ShaderWarningsAsErrors =0
WriteInfoLog =1
WriteProgramObjectAssembly =1
WriteProgramObjectSource =1

Unfortunately I don’t have XP on this machine.

From what I read it controls which emulation features (as emulating newer GPU extensions on older GPUs) are enabled. Setting this value to 7 will probably enable the G80 emulation.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.