No luck with Radeon 9700 (BIOS won't POST)

I installed a Radeon 9700 yesterday in a machine built on a Tyan Trinity 400 motherboard (using VIA Apollo Pro 133a chip set). It booted and ran fine yesterday. I cold booted once (when the card was newly inserted) and warm rebooted several times.

Today, it won’t even POST. It just spins up the drives and hangs, no video out, no beep, no nothing. Putting in another card makes it happy again.

Yes, I plugged in the extra Radeon power.

Tyan’s latest BIOS update is from year 2000, althout BIOS-es for newer motherboards make a lot of mentions of work-arounds for Radeon 8500 cards (no mention of the 9700 yet).

ATI support search doesn’t show much relevant, except for some mention that 8500s may have compatibility problems and a BIOS update is recommended.

I would almost think that there’s some bug making it not work, and that I’m toast for plugging in a new card in an older machine – except it worked yesterday!

As much as I hate to be the bringer of bad news but there is a chance the card is all toast now.

I dont know the Readon but all newer 3d cards use 1.15 volts on the AGP slot (if I remenber correctly its goes like this: AGP 2x=3.3V, 4x=1.15V and 8x=0.8V).

However some older motherboards deliver always 3.3V no matter of the selected AGP mode (there were a slight difference in the AGP slot layout to prevent this but it was missing on some boards…)

I would take that card and try it in another (newer) system to check if its still ‘operational’…


Wonderful. I tried it on an FIC AD11 with the same results.

Checking the BIOS for the Trinity 400, it is set at 4X AGP, and AGP drive control (the only AGP-voltage-like setting there is) is set on Auto. If the mobo is this much out of spec, I sure won’t be recommending Tyan to anyone anymore…

Awright, for people searching the archives:

Tyan Trinity 400 (S1854) with BIOS 1.06 seems to come with the AGP drive strength set to Auto, which as far as I can tell may cause it to be out of spec. This Drive Strength option is not described in the manual that comes with the motherboard. There is no mention of this problem, or the problems it can cause, on the Tyan web site, nor on their graphics card compatibility list. A search on keywords on their site finds nothing. However, if you download a PDF with an updated version of the manual, it documents this option saying “we recommend changing this value to CC” with no further explanation.

Color me annoyed.

Originally posted by jwatte:
If the mobo is this much out of spec, I sure won’t be recommending Tyan to anyone anymore…

I would put the blame on the VIA chipset it doesent comply to the AGP specs 100%.

I allways had problems with VIA based systems they are cr** ehhhh cheap…

You may try to get a replacement Radeon…

Sorry again…

Check your power supply for 5v +/- and 12v +/-. Power supplies can increase or decrease voltage with age. Just something else to check if your system is older. I know your other components run but newer hardware is less forgiving than the older ones. Also the voltage regulator on the motherboard may be out of specs.

Reading between the lines on the Tyan web site for the Trinity 400, and comparing the updated instructions on that site to the instructions in the manual that came with my motherboard, tells me that the problem is most likely with their flawed design.

Their support has not yet replied to my e-mail asking if this is a known issue.