need help with a diagnosis? OpenGL not showing...

:slight_smile: Please forgive my non-tech speak, and the dumb question! I’m just getting into OpenGL.

I’ve got an 8 month old Sony Vaio, It’s got an Intel Centrino Dualcore… GM965 Processor. It doesn’t have a graphics card, it does the processing internally. I very badly need OpenGL to work. I downloaded a benchmark util, fog city, to check it. It allows switching between DirectX and OpenGL. DirectX’s graphics work fine, OpenGL shows nothing. I tried the same program on a computer with a graphics card, worked great. I figured out this problem because I’ve got code that renders an OpenGL image that also shows nothing, but works on other computers. I do have OpenGL32.dll… So bottom line, am I missing something small? Is there any way I can get OpenGL running without having to gut the lappy and adding a vid card? Is there ANY WAY I can get it running using existing hardware? Or Am I just missing something entirely?

Thanks a TON for the help guys, I’m sweatin’ bullets here.

You may try to use Intel tool to detect and update to the lastest driver :