Nasty open gl install problems

Info you’ll need to know:
Voodoo 2 (DX7 drivers - newest screw up comp)
Sis 6326 (newest drivers)

I’ll do my best to explain this, but it’s rather complicated. Well, I was upgrading my Voodoo2 drivers to the latest ones and there was some bad error that happens whenever the computer starts to load up in windows. It completely freezes, sometimes with a little green line pattern near the top of the screen. So I used system restore from safe mode, only problem is that it seems I can’t use Open GL at all, even though I restored it to before the latest drivers were installed.
I’ve tried reinstalling older drivers that came with my hardware etc. but nothing seems to work. Then, I was browsing around looking for the answer when I tried the open gl seup program. It installed some open gl files and now I get the loadup freeze error again. So I just restored the system again… Can’t seem to get open gl to work for anything. Oh, and in case you want to know I was trying to get open gl to work in Counter-Strike and a few mods. It gives me an error that says open gl isn’t supported. I don’t think the card’s broken, because d3d is it’s normal, laggy self. Anyone know how to fix any of this?

I still can’t figure this out. Anyone have any ideas?