My GeForce2 MX200 does not want to work with OpenGL

When I first got my GeForce2 adn tried to play games in OpenGl mode and it didn’t woek I just assumed it wasn’t supposed to. But I have recently found out that it is supposed to and since I just got Jedi Knight 2 I want to make it work.
When I try to run or test most games with OpenGl I get the famous litttle red Windows error:
<insert game executable>
This program has performed an illegal operation and will be shut down.

Since it happens on allmst all of my games with OpenGL and those games run fine in Direct3d I’m pretty sure its not the games.

I’ve talked to the tech support for my videocard for a while and did couple things they suggested: got newest videocard drivers, reinstalled the games, got newest Motherboard chipset drivers and it all didn’t help. So they told me that the problem is definetly software related and that I should research it here…

I’ve tried the GLSetup thingie and it didn’t do anything…

Here’s my computer info:
PIII 1000Gtz
ABit Bx133-Raid Motherboard
Intel 440BX Motherboard Chipset
GeForce2 MX200 with 64 Ram
654,160Kb of Ram(Let’s just say I play EverQuest)
VideoCard drivers version: 28.32
Windows98 OS

So… anyone have any idea what’s wrong?