Multi gpu question

i dont know if i should be asking this here specifically, however, the issue seems to be that vulkan should allow users to choose their rendering device… so for instance… you have 2 gpus in a system… one gpu the person is using for work or heck even physx or mining or whatever the case may be … vulkan then chooses to render on a particular gpu… and may not be the primary device set by the os… so like in doom… 2016 or eternal doesnt matter or any other game for that matter… it tends to select the wrong gpu that the person wants to use … or may select the right one without the person realizing … is there a way to force the api to select one over the other… there are various topics about this on forums all over however there doesnt seem to be a correct answer or solution.

I like ellipsis as much as the next guy, but maybe ease up on the interpunction… :smiley:

In Vulkan, the application selects the GPU. Complain to the application maker. The good ones should have GPU select option.

With some registry hacking though, you should be able to achieve that the preferred GPU is shown first, and the bad apps would assumably pick that one.

Thats what I was assuming, kinda of a pain in the a** though. Seems like all vulkan games and some other renders are all like this which make it an issue for my needs. Like Dx11 or 12 uses the primary display gpu set by windows, vulkan in linux or windows does not.

I mean, there’s no win here. Vulkan simply requires discipline.

Could also be other way around. You run something like Minesweeper, you do not need 9999 W dedicated GPU. The app simply needs to choose the appropriate one.

On notebook, both GPUs are “primary”. TBH I do not, and never understood, what does “primary GPU” even mean.

Anyway, there is already Issue submitted to this: https://github.com/KhronosGroup/Vulkan-Ecosystem/issues/30
Seems abandoned though.

well i just think it makes the os try to render things to that display adapter before others… like this is my system specs:
3700x
x570 mobo
radeon vii
vega 64
16 ram
500 ssd
3 tb hdd

and use it for work and lots of projects therefore i got the radeon vii because of its vram and other things for the price, and i use the vega for gaming. so, im working and gaming at the same time which usually works in 99 percent of games except when it come to games using vulkan because it always forces radeon vii. Also, I set vega 64 as the “primary” display adapter which in dx12 , dx11, and even opl uses it for gaming. So im trying to figure out a work around.

funny thing is , some vulkan games are using the radeon vii and almost doing like crossfire with the vega 64. Its actually kinda funny.

As a workaround, switching the GPU order in registry should work, I think. With usual caveats.

PS: I think Crossfire is mostly PCIe based anyway nowadays, so as long as the GPUs are similar enough (same limits and features), it could theoretically work. I assume they show as a device group in vulkaninfo?

no they are in seperate groups in vulkaninfo

Hm, then how do you know they are crossfiring?

Another workaround would be to use VK_ICD_FILENAMES env variable, and include only the preferred GPU, or order them differently.

you can tell by the gpu usage of each card and the framerate because of the weird dips which are the same from when i used 2 rx 480s in another system