MSVC debugger & OGL

I’m having a wierd problem with the debugger. If i hit Go I expect the program will run as if running the exe directly, except within the debugger environment. This has always happened before, but now, ever since I formatted, reinstalled Win2K, and installed Asus’ drivers for my card instead of the Nvidia ref drivers, every time I hit Go it breaks at the first OpenGL call, ChoosePixelFormat(), and gives me the dissassembly of that. I don’t want to step through all that, I did it for about 2 mins straight without getting to the end of that call, I just want it to run through once. I’ve tried every setting in the config menus but still nothing. Does ANYONE ANYWHERE know how to disable that?

Yes I’ve tried stepping over and stepping out of and running to cursor, but same thing. Every time I hit that function I get it dissassembled. There’s no breakpoint there, there’s no error when compiling either.

I have always got the same type of “error” when I have used ASUS drivers. I have contacted them but have not received any answer. I have posted this issue before on this board and nobody have been able to help me. This forced me to use NVIDIA ref drivers without STEREO. To Baaaad !

What kind of driver forces a debugger to break and not get out of a function?? There’s gotta be some setting to get out of there in MSVC.

OOps. Just found new drivers at NVidias pages. Might solve this issue to let you use STEREO …

Several people have complained about breakpoints in Asus drivers before, apparently they’re only there in the latest “beta” drivers. If you search the forums I’m sure you’ll find lots of info, but I don’t think the problem has been solved. Just use the nvidia reference drivers.

Hurray !

Just verified that the new NVidia drivers work just fine without breakpoints with stereo enabled !

As much as I’d like to use the ref drivers again I’d feel like a sheep for buying a card with all this functionality and not using it…

But I got all the features workin ? What do ya miss ?