Mipmappin in Opengl ES 1.0?


I am trying to do mipmapping and trying to play around with filters but it doesn’t seem to work. I have the following code :


Only texture[0] seems to have a texture. The others seem to have no texture at all. Is this not supported ?


Mipmapping is not used (e.g. effectively turned off for you) if your mipmap is not “complete”. Among other things, completeness requires all levels of the mipmap to be present, down to a map of size 11. If your code snippet above is complete, you are missing definintions for 88, 44, 22, and 1*1.

Hope that helps,

[ October 30, 2004: Message edited by: Hans-Martin Will ]

It works now, Thanks

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.