Mesa 5.1 and 6.0 implementation of ARB_fp

I would like to try a (nice looking) offset bump mapping demo, but I only have a GF3.

The Mesa team claim that ARB_vp and ARB_fp are emulated, but not on a very stable state.

Ok, so I compiled Mesa 5.1 with MinGW under windows, got a nice opengl32.dll, put it under the same folder as the demo executable.
Result : segmentation fault just afer window creation. (without Mesa the prog just says that there is no ARB_fp and stops cleanly).

I had some warnings during copilation of Mesa, but nothing seemed really specially worrying. I tried the Mesa 6.0 release candidate too, at , but it segfaults at the very same point.
Well, I can’t believe that a simple glTranslatef can crash Mesa !!!

As I would really like to work it out, anyone can point me if it is Mesa complete fault, my compilation or MinGW setup, or else ?
I would really appreciate if a someone could test this under linux, as both Mesa and the offsetmap are mostly developped for linux environment.

GDB trace follows :

Starting program: C:\prog\msys\1.0\home\user\offsetmap/offsetmap.exe

Program received signal SIGSEGV, Segmentation fault.
0x61f7cf5e in _swrast_validate_texture_sample ()
(gdb) bt
#0 0x61f7cf5e in _swrast_validate_texture_sample ()
#1 0x61f860ec in fetch_texel ()
#2 0x61f89371 in execute_program ()
#3 0x61f89a3b in _swrast_exec_nv_fragment_program ()
#4 0x61f8fd28 in _swrast_write_texture_span ()
#5 0x61fae3bc in multitextured_triangle ()
#6 0x61f7d1c1 in _swrast_Triangle ()
#7 0x61fb997e in triangle_rgba ()
#8 0x61f59d3c in _tnl_render_tri_strip_verts ()
#9 0x61f5aec5 in run_render ()
#10 0x61f4a3aa in _tnl_run_pipeline ()
#11 0x61f66dde in _tnl_flush_vtx ()
#12 0x61f65bb7 in _tnl_FlushVertices ()
#13 0x61ee5a2b in _mesa_Translatef@12 ()
#14 0x61ea253d in glTranslatef@12 ()
#15 0x004034ca in drawGeometry() ()
#16 0x00403972 in display() ()
#17 0x1000434e in _libopengl32_a_iname ()
#18 0x10003e0b in _libopengl32_a_iname ()
#19 0x10004407 in _libopengl32_a_iname ()
#20 0x00403c4d in main ()

Well, nobody seems interested in software emulation of fp/vp, you all have high-end cards or what ???

I tried many things with the Mesa 6.0 library, it does work with vertex programs, but any fragment program seems to make it crash at strange places. Maybe I will have to wait further.

However, I would be glad that a linux user could test that.


Originally posted by ZbuffeR:
Well, nobody seems interested in software emulation of fp/vp, you all have high-end cards or what ???

You are asking a Windows question in a Linux forum. hint

The only thing I ask is that someone test a linux lib and a linux prog on a computer with a linux OS.


[This message has been edited by ZbuffeR (edited 01-15-2004).]

Have you tried running any of the simple demos in progs/demos/?

I can assure you, Mesa generally works great on Linux.


I have run many GL programs with Mesa, all of them work well. The only crashes I get is when ARB_fragment_programs are used. No problem with ARB_vertex_program, though. Do you have a working fp based program running with Mesa 6.0 ?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.