maya 8.5: // Error: does not match the current architecture

When I try to load the collada plugin in maya 8.5 on my macbook pro (intelmac UB), the output window says:

// Error: does not match the current architecture (COLLADA_m85)

Does anyone have this problem, does someone know a work around or sollution?

I remember dat the same error occors when trying to load the vector renderer in maya which is an intelmac problem… The weird thing is that the collada feelings software company which makes the maya plugin specifically says it works on intel and maya 8.5!!

quote from their website:
The binary provided is for Maya 8.5 only, and has been compiled in universal mode so that it can run on PowerPC and Intel machines equally. … ablePlugin

please help 'cause my deadline is coming!!

Unfortunately I don’t have an answer for you, or an Intel Mac to test on.

It’s possible if you post in Feeling’s forum they’ll be able to help, but as I understand it they’re not going to be working on or supporting the open source stuff anymore; they’ll only be supporting their ‘premium’ plugins which you have to pay for. The free plugins will be picked up and maintained by SCEA and Intel, but the details of that are still being worked out so there’s nobody dedicated to fixing problems in the free version at the moment.

Probably the best solution is to grab the code from Sourceforge and build it yourself, which should get you working binaries.


The Maya 8.5 version should work on the Mac, however I don’t have a Maya 8.5 setup to test it on right now.

Originally, there were some problems with the install script not copying the plugin to the right directory but I thought those were fixed.

Have you tried the latest version of the plugin 3.05b? There were some changes to the install scripts for that one.

thanx for the reply, I’ve placed the plugin in the following directory: Users/shared/autodesk/8.5/plug-ins

the plug-in shows up in maya but when I try to activate the checkbox in the plug-in manager it gives the error:

// Error: does not match the current architecture (COLLADA_m85)

I’ve installed the Cg 1.5 stuff from nvidia and double checked all my directories for the AETemplates files , collada files and the .xpm!

Hi siebejanssen,

You didn’t say which version of the plugin you are using, I need to know that.

If you are not using 3.05b from or from here … _id=136478 please get it and give it a try.

In the meantime I will check the setup of my Mac and see if I can find any more information for you about the problem. I have 3.05b working on Maya 2008, I rebuilt the plugin, but that was mainly because a 2008 version wasn’t in the package at the time.

I’ve installed the ColladaMaya_OSX_3-1.05B… Thanks a lot for helping me! :slight_smile:


Were you able to resolve the error?

I also have this error and looking for a solution, please post an answer here if you find one and I’ll do the same.


It sounds like getting the latest release of ColladaMaya fixed it for him mal80…if it doesn’t work for you please let me know.

Installing the latest version did NOT solve the error! mal80. I already installed the latest version before I posted this problem.

“I’ve installed the ColladaMaya_OSX_3-1.05B… Thanks a lot for helping me!”

was a reply to greg_corson’s question:

“You didn’t say which version of the plugin you are using, I need to know that.”

Hope I made that clear…

I’ve read that installing cg 1.5 sometimes helps, but it didn’t for me…

I’ve also tried using the fbx converter from autodesk but it doesn’t output the right .dae construction used for papervision. I’m testing an application called meshlab which is free, can output collada files and looks promising. I can import the geometry vertices into papervision but now the material attributes are missing in the dae file!! Well… at least the geometry loads… so I guess it’s a start… I just don’t understands why the material doesn’t output…

More help is more than welcome!

Terribly sorry for the misunderstanding…I’m installing maya 8.5 now so I can test this on my machine.

One possible problem is that the plugin got installed with incorrect permissions, I have seen this happen on some systems.

While I’m doing testing, please give this a try…

Use spotlight to search for COLLADA.bundle, hold down the apple key and click on COLLADA.bundle in spolight menu to open a finder window. (or you can just browse through the finder to Users/shared/autodesk/8.5/plugins)
Do a “get info” on COLLADA.bundle
Check the permissions part of the “get info” dialog. If your account or “everyone” doesn’t show up with read access, this may be your problem. You should be able to change the permissions from “get info” dialog.

Just click the little lock icon at the bottom of the window, then select “everyone” from the permissions list and change the permissions to “read only” or “read and write” If your account is on the list, do the same thing for it.

Then try loading the plugin in maya from the plugin manager.

Please let me know if this works for you…I’m doublechecking this in the package now to see if the current version installs this way.

Thanks Greg.
I tried modifying the permissions on the file and it didn’t make a difference.

For the sake of clarity the name of the plug in that came in the download that I installed with ColladaMaya_OSX_3.05B is called, COLLADA_m85.bundle

I did try modifying the filename to COLLADA.bundle just to test and that also had no affect.


Hi Guys,

Sorry for the problems you’re having, I have both maya 2008 and 8.5 loaded now, I re-ran installs from the latest 3.05b package.

It looks like there are errors in both install scripts…after fixing this all the files go to the right places and have the right permissions but the plugins still fail to load so the bundle files must be corrupted.

I’ve rebuilt the 2008 bundle and it now seems to work. I’m in the process of doing 8.5. As soon as both are confirmed working I’ll let you know where to get updates from.

OK, that’s good news. Your effort is greatly appreciated Greg.


that’s amazing greg! hope you can fix the 8.5 version as well! I also made the changes to the correct permissions of the folders and the content, I did what the .sh file said (the file which should run in the terminal when installing the plugin…) So I’d tried that before posting this thread…

Anyway… what did you do to fix the problem for 2008 version?! Lot’s of thanx for your effort, if this fixes the problem I’ll ask my boss to transfer some money to you :slight_smile:

we’re all sitting around the office chanting your name Greg, Greg, Greg.


I have a package with fresh install scripts and fresh builds of 8.5 and 2008.

Both are working fine on my Mac now (the old ones weren’t).

I’m not sure what the problem was with the bundle files, I didn’t actually do anything to them, I just loaded them up in XCode and rebuilt the project.

I’m uploading the new package to sourceforge now, but for some reason it’s going really slowly. The file will be in the current release and will be called and should show up on this page … _id=136478

It’s about 40% uploaded now and only going 3KB/sec for some reason, so it will be a half hour or so before it’s up. I’ll post here once it’s up.

Ok, it’s up now, please let me know if it works for you so I can make the version official.

Before installing make sure you remove any existing COLLADA bundle files from your /Users/Shared/Autodesk/maya/8.5/plug-ins directory, then run the install script provided.

It should install a file called COLLADA.bundle

hmmm. got the files, removed my old collada.bundle files, ran the script in terminal, COLLADA.bundle was successfully copied to the proper directory. (this never worked before)
Opened Maya >> plug-in manager, click on the load check box and I get the same error.

. I wonder if the files are being corrupted during zip or transfer?


checked the permissions on the new COLLADA.bundle. I have read/ write permissions by default, tried changing to read only, still no luck.

Are you sure you got the right file? The download count on my fixed file on sourceforge still shows zero. … _id=136478

I’ll download it myself and try it.