linux core dump with glBegin()

I stumbled upon the nehe tutorial and have found it absolutely incredible,
the depth and clarity make it invaluable. I have successfully compiled
under Delphi, but ultimately want to compile under Linux and finally use
togl to implement a tcl interface. But right now I am stuck. My problem
is such: I successfully(?) downloaded and installed Glut 3.7. I then
successfully got the first lesson to run correctly without drawing anything
on the screen. However, when I tried to run the second lesson (linux source
code), it compiled fine, but on running, it gave me the following error and

GenuineIntel cpu detected.
Katmai cpu detected.
Illegal instruction (core dumped)

This error only occurrs when I try to draw polygons or triangles, or anything on the screen.

I do not know how to make it work and would appreciate it if you could help
me pinpoint the problem. Thank you very much,


Hi Raphaelo,

try out the Linux/GLX Version (can be found at If it works the error has to be somewhere in GLUT/your setup of GLUT.

Otherwise perhaps your is broken or there are incompatibilities with your hardware.

I would check out the GLX-Version first to see if the error persists…

hope this gets you closer to the error…

bxe Miq

Thank you for that link, I checked it out and downloaded the sample lessons, unfortunately after compiling them, they gave me the exact same error.

I am using Red Hat 6.2 on a PII 650 with a voodoo 3 video card.
My GCC version is egcs-1.12 and XFree86 3.36-20 is installed.

Thank you for your help

It sounds like you are using precompiled code somewhere that was not intended for your CPU. Make sure all the bits and pieces are compiled for your machine (binaries and libraries).


I first installed Mesa from some file I downloaded off of the internet. I then went and downloaded MEsaLib-3.2.1.tar.gz amd and installed them both. This time, I had to run make to install all of the files which made me feel better. However, upon recompiling, I still got the same message. Could my original install still be in there causing problems, and if so, how can I get rid of it?


Originally posted by Raphaelo:
Could my original install still be in there causing problems, and if so, how can I get rid of it?

It’s a possibility.

One thing to try is ldd:

[ryants@cr1016134-a opengl]$ ldd myprog => /usr/X11R6/lib/ (0x4009d000) => /usr/X11R6/lib/ (0x4028e000) => /usr/X11R6/lib/ (0x402ac000)

Now check to make sure that these three
things are pointing to the right thing.
You’ll probably have to follow a few

[ryants@cr1016134-a opengl]$ ls -l /usr/X11R6/lib/
lrwxrwxrwx 1 root root 19 Jul 21 00:02 /usr/X11R6/lib/ ->*

if things are not pointing to the right
things, then delete the wrong things,
install the right things, and run

Hope this helps