linking error

my gpu is capable of openGl 4.3. compilation is ok.but y problem is linking error .Unresolved functions while linking.I downloaded glew.h wglew.h ,I down loaded latest drivers for the gpu from Nvidia. slill problem with
liking.linker can not find the functions. I read throgh all forum Faqs.Can any one help me.Please.

Please provide the linker errors and the OS and compiler you’re trying to use.

Ebarcadero xe4 compiler, windows 8 pr0 ,GeForce gtx 660 graphics card.
LINK 64 error: unresolved symbol glewInit refferenced from .o module.
I downloaded:
glew- 1.10.0 from
latest gpu drivers from Nvidia
Added the filePATH to the project through project->options
Inluded: glwe.h, wglew.h ,glut.h in project header

Still the linker error.
thank you

Did you google the linker error? Try these suggestions:

Yes I did the same url. and did everything there. I am targeting 64 bit compiling and linking
thank you

Moved your thread to the Windows forum where you might get more help with this Windows linker error.

Obviously you aren’t successfully linking with the GLEW library. Would double-check the path-to and name-of the library you are providing, make sure the compiler is trying to link with that, and verify that the architecture of the library matches the architecture that you are compiling for (e.g. 64-bit).

I have my embarcaderoXe4 compiler in C:\program Files\Embaecadero\RAD Studio
and glew 1.10.0 in C:\program Files\Embaecadero\glew
and Nvidia drivers in C:\program Files\NVIDIA\

Do I have to include the bin paths to the projects
And add the GPU drivers path to the project if so how.
The error::Checking project dependencies…
Compiling skeletonTreeProject1.cbproj (Release, Win64)
“C:\Program Files (x86)\Embarcadero\glew\glew-1.10.0\bin”;
“C:\Program Files (x86)\Embarcadero\glew\glew-1.10.0\lib\Release\Win32”;
“C:\Program Files (x86)\Embarcadero\glew\glew-1.10.0\lib\Release\x64”;
“C:\Program Files (x86)\Embarcadero\glew\glew-1.10.0\lib\Release MX\Win32”;
“C:\Program Files (x86)\Embarcadero\glew\glew-1.10.0\lib\Release MX\x64”;
“c:\program files (x86)\embarcadero\rad studio\11.0\lib\win64\release”;
“c:\program files (x86)\embarcadero\rad studio\11.0\lib\win64\release\psdk”;
“C:\Program Files (x86)\Embarcadero\RAD Studio\11.0\lib”;
[ilink64 Error] Error: Unresolved external ‘glewInit’ referenced from E:\XE42013NOVEMBER\GL\WIN64\RELEASE\OPENGL64ADT.O
[ilink64 Error] Error: Unresolved external ‘wglewIsSupported’ referenced from E:\XE42013NOVEMBER\GL\WIN64\RELEASE\OPENGL64ADT.O
Elapsed time: 00:00:24.8

Thank you

can any one help me in this mater of linking opengl. /thanks in advance, akhan45

when I tried to compile a program with directx I am getting the same linker error
[ilink64 Error] Error: Unresolved external ‘D3D11CreateDeviceAndSwapChain’ referenced from C:\MY PRORAM FILES\DX\DX1\WIN64\RELEASE\DXADT.O
So the error is in adding the lib files to the project,which I am not able to solve.Any help?

This is very good. so many days no help from any one.I think no one ever use opengl for programming.Even the embarcadero company is not giving any help in there help system for adding third party libraries,through the “project options”.I hope some software maker comes with good development Platform and frame for easy programming.Now, one has to spend days ,in setting up the development frame for any result,if at all there is any result.

                        Does linker error has any thing to do with packages?

No, quite a few folks use OpenGL and DirectX (as you said, you’re having problems compiling both). I think what this indicates is that you need to provide more information. There’s nothing obvious in here that’s saying to someone “ah! that’s his problem!”.

Whip up a short stand-alone test program, compile/link it with a standard Windows compiler such as MSVS (ditch that Ebarcadero xe4 compiler temporarily; that could be your problem), and if errors, post those along with the full options you are using to compile and link.

If you don’t get any errors with a standard compiler, than you know you’ve isolated it to being a problem with the custom compiler you’re trying to use. And then you know you need to investigate FAQs/forums/etc. for that compiler specifically.

Have you tried asking for help at the GLEW users mailinglist? Here, it is like asking the alternator guys on problems connecting engine and gearbox. Sorry for the bad analogy :wink:

Thank you sirs. Let me download msvs 2010 and try again. I will post the results. Thanks again.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.