I’ve included glaux.lib to my project.
I’ve done the following steps:
1.generate the glaux.lib using the run command.
implib.exe glaux.lib glaux.dll
2.the glaux.lib file I moved to folder /Lib my project I added the line: #include <GL\glaux.h> and also
#pragma comment (lib,“glaux.lib”)
And if I try to compile any project the linker error appears, something like this:
[Linker Error] Unresolved external’auxDisplayMode’referenced from …\file.obj
The same project works well at school.
You know I don’t have a clue what’s the hell’s goin’ on !!!
btw. I use Borland C++ Builder 6(like at school)
I also tried to use the glut library in my project and the linker alse appear (unresolved external’glut…’)
I think the problem is because my Borland C++ is not installed in a default directory(whats more it is installed in another phisical disc)
Maybe there are some options which I have to set int Borland ???

Maybe your compiler doesn’t allow adding libraries through pragma directives. Add glaux.lib in the project settings instead.

this might work:

take the “.lib” off from the “glaux.lib” in the #pragma


#pragma comment(lib, “glaux”)

because you tell it it’s a lib, it knows the extension - it would have been looking for

Not sure but try it.