LIBGL_ALWAYS_INDIRECT causes glxinfo failed on local machine

#1

I am playing with OpenGL environment variables. I tried with indirect rendering but it generates the following error:

$ LIBGL_ALWAYS_INDIRECT=1 glxinfo
name of display: :0
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  34
  Current serial number in output stream:  33

glxinfoworks fine without setting LIBGL_ALWAYS_INDIRECT.

$ glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
...
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
...
GLX version: 1.4
...
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NVE7 (0xffa)
    Version: 11.2.2
    Accelerated: yes
...
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVE7
OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.2.2
... 
OpenGL version string: 3.0 Mesa 11.2.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
...

I tried both commands on another Linux computer and both work. It seems that the first computer has some setting that prevents it from using indirect rendering. What it is?

#2

Found this link which answers my question, plus a lot of useful information

https://www.scm.com/doc/Installation/Remote_GUI.html