latest revision

On Linux64 target i’m unable to build the dom.
It miss some zip64 functions.
I’ve commented this lines but when running DAE not read any (non zae but dea) document and segfault with the simple add(…) and writeAll().

An issue ?

Previous svn from one year (r 844) worked fine for me.

r 878 segfault too but compile (excepted test).

how to have a buildable version and compatible with a boost 1.49 or 1.50 ? and why using boostfilesystem that make hard dependencies for a ridiculous feature ?

segfault is due to a null ptr topMeta in daeSTLdatabase.

EDIT: finaly the bug was due to a missing COLLADA_DOM_SUPPORT141 define. its now OK with a modification in

i’m the maintainer of collada-dom, we’re thinking of releasing 2.4.1 soon for minor improvements. it looks like you solved your problem, but if you have any issues with the new way of managing 1.4.1 and 1.5.0 namespaces, please tell us.

By the way, we don’t support the dom/make/ files anymore. Only the CMakeLists.txt files are used (cmake)