JK2 and Windows XP

I need help. This may or may not be an OpenGL problem, but you all might be able to help me. I am currently running Windows XP with an AMD 1800, Soyo MB SY-K7V DRAGON Plus!, Asus ASUS AGP-V7700 Deluxe video card, 768 megs of RAM. I am having a problem with running Jedi Knight 2, which I have also had the same problem running Unreal Tournament and Max Payne. The problem is the game will freeze after about 5 minutes (if I’m lucky, it will play a little longer). I have tried installing the OS itself on a different HD and just the game, but the same thing happens. I have tried the default Microsoft drivers, but it gives the OpenGL error message so I have to load the manufacturer/NVidia drivers. I’ve loaded two different Asus driver versions and the NVidia reference driver with the same result. When it does freeze, I am able to hit the Windows key, an error window pops up, which I close and brings me to the desktop. Only problem with that, is that it retains the brightness setting from the game, so I have to go back into the game and then close it just to get back my regular desktop setting. Any help would be appreciated, as I hate to be interrupted every 5 minutes from my gaming. If you need more info, let me know and I will post. Thanks in advance.

When you hit the windows key after it freezes, what does the error message say? Anything useful?

Other thoughts are…

  • Do you have antivirus or backup software that runs intermittently?
  • Are you overclocking?
  • What kind of case are you using, is heat a possible problem? Perhaps try opening the case and point a room fan in there to remove any doubt of heat issues.

See if any of that helps, and I’ll try and brainstorm some more.

edit: I saw a reference to an issue with that board and the Asus Geforce3 Ti500, but since you’re not running that card, it shouldn’t be an issue. Here’s the link to the article if you want to check it out, compatibility is discussed on page 6: http://www.lostcircuits.com/motherboard/soyo_k7v/

[This message has been edited by yakuza (edited 05-09-2002).]

Hi Yakuza, thanks for the reply. I’ll post the error message tonight, but here are the answers to your questions:

  • no, I don’t have a antivirus or backup software running in the background
  • no, I am not overclocking
  • I thought it could be something with my case, so I bought one last weekend. I got an Antec SX1030.

I might add also, last night I put Windows 98 on another hard drive, installed drivers, added any updates and loaded JK 2. JK 2 did error out, I looked at the error message and it did say something about OpenGL. I downloaded and updated OpenGL, but didn’t have enough time to try it out last night.

I will check out the other site. Any other information would be greatly appreciated. Thanks.

[This message has been edited by gonzo369 (edited 05-10-2002).]

[This message has been edited by gonzo369 (edited 05-10-2002).]

Those Antec cases are sweet, we’ve got about a dozen of them in our test lab, and I’ve got an 840 at home. So I doubt heat is an issue, unless you’ve got your machine sitting next to your heater vents.

That board uses a Via KT266a chipset, so make sure you have the 4-in-1’s installed http://www.viaarena.com

You could also try turning down the AGP settings in the BIOS, maybe 2x or even 1x, disable fast-writes, etc. Your BIOS might have a “Load Fail-safe defaults” option or something, that’s worth a try to see if it fixes it even though it will reduce performance. Also, BIOS updates from Soyo could resolve the issue, particularly if turning down AGP/performance settings fixes things.

Without seeing the error message, I’m afraid I don’t really know what else to say.

Let us know what you find out.

edit: Oh yeah, I haven’t played that game, so I don’t know if this is applicable or not, but make sure you have any patches for the game that are available.

[This message has been edited by yakuza (edited 05-10-2002).]

Hi Yakuza,

I have installed the 4-in-1’s with no success. I’ll try tweaking the settings in the BIOS and see what happens. The error message I get is very long (otherwise I would have posted for your viewing). They just released a patch, so I installed it and it’s still freezing on me. I’m trying to borrow another AGP video card to see what happens. I’m wondering if it is my card. I’d hate to have to go out and buy another one. Thanks.

It might be extremely helpful to see that error message… although it’s possible it wouldn’t be helpful at all.