Issue with OpenGL drivers since reinstalling Windows

Hello! I’ve been having an issue with my opengl drivers since reinstalling Windows on my Dell XPS 15 9570 laptop, and I’ve been unable to resolve it myself after trying for a couple days. Basically, sometimes when I try to create a window with GLFW, I get the “WGL: The driver does not appear to support OpenGL” error. The odd thing though is that after I restart my PC, the window is created without a problem, but if I put my laptop to sleep and reopen it (i.e. shut the screen and reopen it), the drivers then stop working. I’m no expert on the Windows OS and I cannot for the life of me imagine what could be causing this strange issue. I have tried reinstalling the graphics drivers for my GPU model (GeForce GTX 1050 Ti) on Nvidia’s website several times, as well as all of the drivers for my laptop supplied by Dell. Obviously it’s not a super big deal, since I can just restart my computer every time I want to use OpenGL, but it is still a significant burden to have to worry about this whenever I want to start programming. I’d really appreciate if anyone has ideas or suggestions for how to fix this issue!

Wild guess: sounds to me that the discrete (Nvidia) GPU is not properly coming back from the sleep state and you are running with the integrated (Intel) GPU of your main processor. Assuming that is the case you could check the Dell support page for your laptop, maybe you are missing drivers for some other system component(s) that is responsible for handling this wakeup.
You could also try to install Intel graphics drivers - after a sleep you might end be running on the integrated GPU instead of the discrete one.
Or (if possible) disable the integrated GPU in the BIOS to make sure you are always on the Nvidia hardware - that may of course have a negative impact on battery life and if the Nvidia hardware still does not wake up correctly after a sleep you may no longer get anything displayed.

Well I really appreciate your response, but after another day I’m still at a loss. As far as I know I have all the needed Dell drivers already (I have the “Dell command update” program that automatically installs/ updates all needed drivers), so I tried going into the BIOS like you suggested. Interestingly, my GPU doesn’t even show up in the BIOS, and I thought this was odd so I updated my BIOS but still no luck. I then tried to disable the Intel integrated GPU in Device Manager, therefore forcing my computer to use the discrete Nvidia GPU instead. This also doesn’t work, and I can see by going into the Task Manager that the integrated graphics is no longer listed, but I can also clearly see that the Nvidia GPU isn’t being used at all.

It might also be worth noting that I recently did a clean reinstall of windows 10 on my PC, but this problem also existed before on the original windows 10 installation. That makes me wonder if the problem is something intrinsic to the hardware/ computer itself rather than the drivers/ operating system. (My GPU definitely works though; I’ve used it successfully many times in the past.)

I’m starting to feel like this problem is too specific to be applicable to anyone else, so I’m probably just gonna keep looking for a solution myself. Thank you for your advice and I’ll make another post if I ever manage to solve the problem.