Issue loading files with OpenGL enabled.

Hi all,

I don’t know if this is the right board for this, so please move it if its in the wrong forum. I need help. I have several CAD style applications that can not load files when OpenGL is loaded. This only happens on Core2Duo machines with nvidia cards. Here is the scenario:

I double click a file which should load my 3d software application for viewing the file (Similar to how you can open a document file to launch word). The application will load, however, it states that the file is not found. If i turn OpenGL rendering off, i can double click the file and load it just fine. Also, if OpenGL is enabled, i can drag and drop the file into the already open program and it loads the file.

Again, this is only happening on machines running nvidia cards on core2duo chips.

I have tested it with 4 different models of nvidia cards(8800gt,7900oc,fx570,fx1400), and 2 models of ati cards(HD2400pro, HD3850). All six machines are the exact same setup with the only exception of the video card.(C2D E8200 2.66Ghz, 4GB ram) They are all pulling the same file from the same remote location, as well as from their desktop.

My question is, does anybody know any possible work arounds short of buying ati cards for all these machines? Such as different drivers, possible bios settings,general settings or the like.

Thank you for reading my wall of text, and your help.

What OS and driver version do you have ?
Which applications ?
Try to contact nvidia about this.

All the machines are running Windows XP SP3. The drivers don’t seem to matter, as I have tried the latest drivers, all the way back to drivers from six months ago, and everything in between.

The applications it affects are:
SolidView/SolidView Pro
SolidWorks2008 and 2009
Actify Spinfire
Pro Engineer Wildfire 3.0 and 4.0

Maybe the nvidia driver use some problematic threaded driver optimizations. This is something that can be turned off in the Nvidia control panel, not sure the exact name.

So i checked through all the settings. I saw the threaded application setting, and tried it with Auto, On, and Off. No changes. I also disabled everything possible in the nvidia control panel and still nothing. :frowning: Any other ideas?

Sounds more like a application programming issue.
It is not likely to be related to nvidia’s multithreaded driver. The issue with that is that in some applications, performance is worst.
Contact solid works. The buffer in which they store the file path is probably getting corrupted and most likely it’s their code that is bad.
Tell them to print out the file path.

Is the application using the DDE to launch is files? If it is, this might be similar to this issue with DDE if the application does something time consuming (e.g. OGL initialization) while it processes messages during its startup.